I have a Dell PowerEdge 2950 getting a "PCIe Degraded Link Width Error : Internal Storage Slot" its out of warranty so I can't harass Dell about it, thought i'd see if anyone here has experienced this.

I have already removed and reseated the backplane, riser card, RAID controller, and the RAM on the Controller. Even removed and reseated all the drives and booted the server without the RAID card, then shut down and installed the RAID card. I didn't get the error when the RAID card was removed so i'm thinking the error is directly related to the RAID card somehow...however, I can still access the RAID BIOS and see the status of all the drives, which shows everything to be ok. I can not access the Dell BIOS though.


Your RAID controller card (probably a PERC 5/i) is in a multi-lane PCIe slot (probably x8), but it is operating with fewer lanes than optimal (probably either x4 or x1). It may still work fine, but if it does work, its maximum throughput for sequential read/write operations will be slower than normal.

Troubleshooting steps:

  1. Try the same RAID controller in a different PCIe slot.
  2. Try a different RAID controller in the same PCIe slot.
  3. Try a different PCIe riser card.
  4. Try a different motherboard.

As a side note, if you are using out-of-warranty hardware in a production environment, it is essential to be self-sufficient with spare servers and spare components.

  • Hi Miles, thanks for the direction. As far as working fine, after I get this error it tells me the system is halted and I can't get beyond that point so its not working at all. You are correct that its a PERC 5/i but I thought there was only one slot for that card. I'll try your other suggestions and see if I can't get this thing running again. Thanks – user72593 Dec 15 '12 at 23:45
  • I don't have a PE2950 on hand for reference, but it is pretty common for them to have redundant controllers. Ergo, I'd think that there ought to be another appropriate slot available in there. – Skyhawk Dec 16 '12 at 22:33

I just ran into this issue with my 2950 server. In my case, it happened when I added a new quad port gigE adapter to the machine. I already had a dual port gigE adapter on the same pcie riser (on the left side looking from the front). If I took the dual port card out the error went away. I'm taking a guess thatthe problem is that the riser doesn't actually provide enough channels to support the full bandwidth for both pcie slots on the riser and maybe is sharing channels with the perc 6/i card. I'm going to try putting one of the cards in the riser on the right side later, but I can't shut the machine down again right now.

  • 1
    I had a chance to shut it down again this morning. Putting the dual NIC in the right side riser worked just fine. So, apparently the pcie ports on the left side are overprovisioned when a perc controller is used. – stuckj Dec 7 '14 at 21:38

Unintuitively, an answer on a Spiceworks question suggests it can be affected by what USB devices are plugged in.

My colleague tells me he has just solved this error on a PowerEdge 1950 by removing all USB devices, which I believe were just a standard keyboard and mouse.

It seems like a long shot to me, but it's at least fairly painless to try.


So your RAID-controller is somehow broken.

If your are lucky, and you did use RAID1 the following will work:

  • Turn off the server
  • pull out all drives
  • Turn on, go into BIOS and switch RAID to SCSI or SAS for all channels
  • put drives back in
  • Confirm "y" for the RAID to SCSI change during boot for every channel

Now you will be able to access your disks as JBOD. You should be able to boot from disk1 - after that you can build up a software raid1 with OS means (I recently did this on an old 2850 with PERC4i/SCSI and Linux without data loss).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.