2

I had server with old Xeon DP and Windows 2008 R2 , With hyperthreading enabled OS saw 2 CPU cores. Recently I've added second same Xeon DP , but OS steel sees 2 CPU cores. I did uninstall all cpu's as in Microsoft KB (tried reinstall also).

The situation is : Two same processors are in server.

  • When hyperyhreading is enabled, OS sees 1 processor (in system info
    window) with 2 CPU cores (in task manager). (device manager shows 4
    CPUs)

  • When HyperThreading is disabled, OS sees 2 processors (in system info windows) with 2 CPU cores (in task manager). (device manager shows 2 CPUs)

How to make Windows 2008 R2 see 4 CPU cores, with two single core hyperthreading-enabled processors ?

8
  • 1
    What edition? This may well be a licensing issue. Commented Dec 17, 2012 at 19:20
  • As @DavidSchwartz said, which edition are you using? Also, it must be the same exact model/part number Xeon as the one currently installed. Sometimes, you can buy the same model - however, it could be a little different. I've run into this issue with Dell before. I would double check to make sure they're identical. Commented Dec 17, 2012 at 19:28
  • If you boot a Linux LiveCD does it see all the processors you expect?
    – Zoredache
    Commented Dec 17, 2012 at 19:55
  • WIndows 2008 R2 Standart edition, Both Procs are are completly identical same part number, This is HP dl 380 g4 with two Xeon DP Irwindale 3.6 Ghz 2mb. On same server model this two procs were seen as 4 cpu cores in win2008r2 but hyperthreading was enabled during OS install. As I understand there are settings in windwos registry that are controlling os behavior about number of cpu and cores. OS device manager sees 4 cpu cores with Hyperthreading enabled and 2 cpu cores with Hyperthreading disabled
    – SalimQrdl
    Commented Dec 17, 2012 at 20:02
  • Actually I had 3 servers : 1 with 1 xeon 3.0 , 1 with 2 Xeon 3.2 , 1 with 2 xeon 3.6 (second and third servers had 4 CPU cores wisible). Last with 2 xeon 3.6 died (ilo not intializing) so I replaced 1 CPU on first server with two CPUs from last server.
    – SalimQrdl
    Commented Dec 17, 2012 at 20:10

1 Answer 1

1

After hours of digging into ways to change HAL in Win2008R2, I've met advice in technet to another question to edit advanced boot setting via msconfig (lowering cpu number , concerning that exact question).

I did following: run msconfig.exe under boot tab click advanced options and unchecked "Number of Processors" checkbox. It was checked with number 2 (maximum allowed number present in list) before.

Then I rebot and voila! Have 4 cores present in Task Manager. Have 4 numbers available in the list in "Number of Processors" in advanced options in msconfig.

Shaitan Have no idea why and when boot options were changed before problem arises but now everything is ok.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .