I am trying to checkout into the virtualbox shared folder with svn 1.7 in ubuntu 12.04 running as a guest on a windows 7 host. I had read that this error was a 1.6 problem, and updated - but am still receiving the error:

svn: E000071: Can't move '/mnt/hostShare/code/www/.svn/tmp/svn-hsOG5X' to '/mnt/hostShare/code/www/trunk/statement.aspx?d=201108': Protocol error

I found this blog post about the same error in a mac environment, but am finding that changing the folder/file permissions does nothing.

vim .svn/entires just has the number 12 - does this need to be changed?

Thank you for any assistance!

(just another reason for why I prefer git...)

  • I have also tried creating a symlink to the repo (which I can checkout into other folders.) but am running into the read-only file system error. Which, is not fixed by issuing VBoxManage setextradata ubuntu VBoxInternal2/SharedFoldersEnableSymlinksCreate/hostShare 1 – Alex Waters Dec 18 '12 at 20:00
  • Now when I try to create a symlink it throws 'protocol error' instead of read-only file system. – Alex Waters Dec 18 '12 at 20:00

There is a question mark in the filename to which you are trying to move the file.
That is not a legal character in a file on NTFS file-systems.

Generally I found the shared folder function of VirtualBox unreliable and after trying multiple times I always went with a standard Windows network share - which might also not help in your case though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.