2

First thing this morning, I find that users on one of our share drives are all getting "access denied". I tried the same drive and also received "access denied" as a Domain Admin. Previous to this, all specified users and admins could get access.

  • I checked share permissions
  • I checked NTFS permissions
  • I temporarily made both types of permissions read/write to "Everyone" -- This worked for one user
  • It turns out that this is occurring for only some files/folders. When I try to manually alter the share of that single share, it can't be shared, access denied.
  • xcacls also gets access denied
  • rebooted the server (not a big deal - this is a smallish company).

Does anybody have any insight, my google-fu is coming up blank. Thanks.

EDIT: More info, I just ran AccessEnum. There were a lot of "access denied", but I noticed the pattern that all of the access denied had a parent with an owner of "???". When I look at the properties, the "Unable to display owner" message is in the box and I can only make my user account the owner. I can then share the individual file/folder, but it doesn't seem to propogate down to subfolders/files.

  • Who's listed as the folder owner? Have you tried to reclaim ownership of the folder? – DKNUCKLES Dec 19 '12 at 16:33
  • I did. I can only make me the owner. If I try to make anyone else owner (including our generic domain admin account), it says access denied. – Tim Dec 19 '12 at 17:03
0

Take ownership of the share and the subfolders, then reapply the relevant permissions. Then turn on File Auditing for permissions changes to determine what process is messing with the permissions should this happen again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.