I have a new WinXP machine that won't allow other Windows machines to map drive letters to its shares. Windows Update was allowed to update everything it wanted a few weeks ago multiple times until it finally said everything was up to date. This includes service pack 3.

I have the C: drive shared as "disk" and all the permissions that I know of set to allow other machines to map to it, but none of them can. When trying from another WinXp machine, it asks for a password, and then the window just pops away without any error message but without having mapped the drive. I have the same user name and password on the other machine, and I have also tried explicitly supplying the user/password for the share machine before trying to set up the mapping, but same result every time.

Someone went thru the server machine and "cleaned up" services that supposedly aren't needed. Possibly something is shut off that shouldn't be. I'm no whiz at this, but I have looked thru the server list and nothing obvious jumps out that isn't already turned on. The descriptions are pretty sparse though, and some of them are alphabet soup over my head.

How do I proceed to eventually get shares from the server machine mappable as drive letters on other machines on the LAN?

Added in response to various questions:

This was run on the server machine in response to a request:

C:\>net use * \\winxpserver\c$
System error 53 has occurred.

The network path was not found.

I tried completely turning off the firewall on the server, but this made no difference. I put the original firewall settings back, which is the firewall enabled with these exceptions:

  • Can you ping that machine by name? Are you using DNS internally? If so, is there a record for that server in your internal DNS zone? If not, do you have NetBIOS enabled? IS the "server" on the same subnet as the client trying to access it? – MDMarra Dec 19 '12 at 18:08
  • @MDMarra If it were name resolution related, I think he'd be getting error 53 instead. So yes, I would start looking at NetBIOS junk next. – Ryan Ries Dec 19 '12 at 18:11
  • Actually, there should be a space between * and `\\`. Is that a typo, Olin or did you actually run the command like that? – MDMarra Dec 19 '12 at 18:12
  • @MDMarra: Yes, I can ping the server machine from other machines on the LAN. We don't have a DNS zone (that I know of). No DNS in use locally, a few hosts files (yes I know that's primitive). NetBIOS is enabled as far as I know, but I may not know all the places that needs to be done. Yes, all machines are on the same class C subnet. – Olin Lathrop Dec 19 '12 at 18:15
  • @MDMarra: Sorry, I didn't notice the space in Ryan's message. Fixed, above. – Olin Lathrop Dec 19 '12 at 18:17

I say this in the nicest possible way, but your question gives me chest pains.

WinXP is not a server. Even if conceptually to you it is, it's not a server. As such, there are going to be limitations as to how many simultaneous SMB connections (other people trying to access your shares) that it will allow.

(Limit 10: http://msdn.microsoft.com/en-us/library/bb147520%28v=winembedded.5%29.aspx)

Secondly, never share out the root of a logical drive. Please. Make a folder on the drive and then share that.

Thirdly, and still good sir please know that I mean you no offense, but the phrase "new WinXP machine" is an oxymoron.

Nextly, if your intent is truly to share out the entire C: drive, then I'm assuming fine-grained access permissions are not a top priority for you, so don't even worry about creating a network share manually, just map to the administrative share \\computer1\\c$ instead.

Edit: Ok, if the error was name resolution, I believe you'd be getting error 53 instead of 67. The error 67 indicates to me that maybe NetBIOS is disabled on one or the other network adapter.

Edit some more: Ok, the error changed to 53 network path not found. Since we can't know what that someone went through and "cleaned up" on that machine, it's hard to say. But we know you have name resolution since you can ping by name. Next comes having NetBIOS enabled. Make sure "File & Printer Sharing" is enabled... beyond that, I'm out of ideas.

  • This is in a small office on a small LAN. Everyone here is trusted and knowns the administrator password, for example. This was all working fine with the Win2000 machine the new machine replaced. I just want to get back to what we had and get back to real work. So, do you actually have a solution? We'll never hit 10 connections, not by a long shot. – Olin Lathrop Dec 19 '12 at 17:57
  • What does it say when you type net use * \\winxpserver\c$ – Ryan Ries Dec 19 '12 at 18:03
  • "The network name cannot be found". I added the details to the question. – Olin Lathrop Dec 19 '12 at 18:07

I did some more digging around and sortof accidentally got it working. I still don't know what the original problem was, but it works now.

I went to Administrative Tools > Computer Management. In there you can go to System Tools > Shared Folders > Shares. That gives a list of all the shares in the right pane. You would (well, maybe not someone that knows what they're doing, but I did) think you could manipulate shares here, but there seems to be nothing that can be done with shares from here. Highlighting a share and doing Action or right click only brings up the option "Refresh". Not very helpful.

Then I tried Storage > Disk Management, still in the Computer Management console window. That showed the C: drive as being called "disk" which is the name of the share for that drive. In here "Action" shows the entry "All Tasks", which expands to another menu which includes "Properties". It's like they are trying to deliberately hide this stuff. That brings up another little window with five tabs, including "Sharing". Now I know despite the obscurity of this window, I had been here before looking for settings. As far as I could tell, the settings were right for sharing, but they apparently weren't. In the section "Network sharing and security", there was a option to run the network setup wizard. The network had been previously set up, so I didn't run this before, fearing it would make a mess and reset a bunch of settings I had already made. After all, I was up and running and able to get out onto the network from this machine.

This time I was more desparate and ran the network setup "wizard" (am I the only one that thinks that's stupid name?), and patiently answered all the question to things that were set up a while back. This included enabling file sharing, which I know had been enabled someplace in some obscure menu before. However, running the setup wizard must have set something else that apparently can't be set in some other obvious way. The really wierd part is the little window where the Network Setup Wizard was run from looked different when I got back there:

The offer to run the network setup is no longer there, and and the two check boxes you see checked appeared in it's place. I don't really understand what exactly wasn't enabled before, but apparently you have to run the network setup wizard once, not make all the network settings some other way. I'd be interested to know what exactly happened, why it didn't work before, and what setting was changed to make it work now, but at least the immediate problem is solved. Hopefully this record can be useful to someone else in the future who runs into the same issue.

  • +1 for fixing your problem. Sorry I didn't hit a homerun with my answer, but I didn't have any XP machines to test on, was just going off of what I remembered from long ago. :) – Ryan Ries Dec 19 '12 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.