Now this is weird!

I am trying to install a WordPress website on a Amazon EC2 server with Ubuntu 12.04 LTS and [amazon RDS][1] database service.

I have installed apache and wphp and ran the required tests (again and again actually) if something is wrong there.

But when I go to the root of WordPress folder (also the root of the server i .e. folder "www") I get this error

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Yes this is pretty obvious because I don't want to install MySQL on my system.

The funny thing is I tried searching it online and there are examples of tons of WordPress websites running on RDS and I couldnt find a single page with this issue.

Any solutions/suggestions?

Is is that i'll have to install MySQL on my system even though I don't want to use it . Doesn't it skip the whole point?

Thanks in advance

Edit : I didn't even reach create configuration file page. The index.php file pretty much showed this error and nothing else.

here is the tutorial i was following : http://www.slideshare.net/mrjain/installing-wordpress-on-aws check out slide 16 it never mentions installing mysql

  • Where are you expecting the data to be stored since you don't want to install mysql? Did you have another mysql server somewhere? Where you thinking you could use sqlite? Were you expecting it to magically just handled by the cloud fairies? – Zoredache Dec 19 '12 at 20:09
  • not fairies actually but this. slideshare.net/mrjain/installing-wordpress-on-aws. slide 16. they did it on amazon linux ami but for ubuntu it coundnt have been much different ! thats for your constructive comment though ! – Danny Dec 19 '12 at 20:24
  • @Zoredache Amazon RDS is a managed MySQL installation. Amazon handles running the database. Basically, this is a question about setting up WordPress with a database on a different server than the WordPress install, which is quite common for scaling. – ceejayoz Dec 19 '12 at 20:33

You don't need to install MySQL server, but you do need the client-side stuff for PHP.

apt-get install php5-mysql should do the trick.

  • it says invalid opertation php5-mysql even tried with sudo in front same thing (sorry if i am sounding like a noob i am just a linux beginner) – Danny Dec 19 '12 at 20:35
  • Sorry, I forgot the important bit, install! Fixed! – ceejayoz Dec 19 '12 at 20:37
  • it installed correctly but the solution didnt work thanks for the response though! – Danny Dec 19 '12 at 20:48
  • You may need to reboot your web server after installing this. – ceejayoz Dec 19 '12 at 20:49
  • and if that doesn't do the trick, try apt-get install mysql-client and another Apache reboot too. – ceejayoz Dec 19 '12 at 20:50

you need to install the php-mysql part of the binary.

yum install php-mysql php-pdo

you might want to look for any other pecls you might be missing,

yum search php
  • 3
    He said it's an Ubuntu system. – Michael Hampton Dec 19 '12 at 20:10
  • sorry did miss that bit. altho ubuntu has a similar setup in the pecls each being different packages to be added. [amazons own linux is based on ubuntu with yum added in for some weird reason.] – WhyteWolf Dec 19 '12 at 20:12
  • well this was the same solution as the the one i marked the answer . but he gave the correct code . Thank You For The Response Though!:) – Danny Dec 19 '12 at 21:18

You must install MySQL client for WordPress: http://wordpress.org/about/requirements/

  • Yes, but you don't necessarily need the server installed on the same machine the PHP's installed on. – ceejayoz Dec 19 '12 at 20:32
  • agreed with @ceejayoz on this ! THank You for response though ! – Danny Dec 19 '12 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.