I have been trying to update the upload_max_filesize of my php.ini file to 200M. I have got it to successfully save however it is not reflecting the changes on my server (it still lists the upload_max_filesize as 2M. I did do a httpd service restart, and I created a phpinfo file which says that it is in fact loading the /etc/php.ini configuration file.

One thing I have noticed is that the libphp5.so file is not reflecting this change. I have done service restarts, and force reloads, and have not been able to successfully get the size to change.

Any help on why this is not changing would be greatly appreciated.

edit: Here's an image of some of the settings for reference: http://i.imgur.com/AmenR.png

  • What about clearing your browser cache? Or try with another browser. – John Siu Dec 20 '12 at 22:04
  • Can you please tell me the output of this command: cat /etc/php.ini | egrep 'upload_max_filesize|post_max_size' – Napster_X Dec 21 '12 at 16:52

Have you tried rebooting the entire server, just to ensure that everything has been restarted?

Have you also looked in the apache config to see if it has been overruled by any options in there?

  • I just completely restarted the server, and unfortuantely that does not seem to have resolved the issue. I also searched through the config file and did not see anything that seems to predefine it. – Mike Dec 20 '12 at 16:29

OP back. I figured out the issue. I ran php -c /etc/php/php.ini -i | grep upload_max_filesize and discovered a small typo elsewhere in the php.ini file. (I attempted to edit the timeout value, and had left in a parenthesis). After taking out the parenthesis, and restarting the service, the upload value was correctly adjusted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.