Windows Server 2003 R2 (x86) / IIS 6.

I'm setting up an ASP.NET application as well as a few windows services that run under "MyServiceAccount". I'm unable, however, to get the app pool nor the window services to start.

The MyServiceAccount is in IIS_WPG, has the appropriate local policy rights and NTFS permissions, and I've even tried granting it local admin.

The app pool fails repeatedly and is stopped automatically by IIS. The error I see in the system event log is:

A process serving application pool 'MyAppPool' terminated unexpectedly. The process id was '7976'. The process exit code was '0x80'.

The window services fail immediately upon the start request, and the error logged is:

Timeout (30000 milliseconds) waiting for the MyService service to connect.

My research indicates that an exit code of 0x80 is often related to desktop heap exhaustion. I ran the dheapmon tool from Microsoft and it suggests that there is no heap pressure:

Desktop Heap Information Monitor Tool (Version 8.1.2925.0)
Copyright (c) Microsoft Corporation.  All rights reserved.
  Session ID:    1 Total Desktop: (  4288 KB -    3 desktops)

  WinStation\Desktop            Heap Size(KB)    Used Rate(%)
  WinSta0\Default                    4096             11.5
  WinSta0\Disconnect                   64              4.0
  WinSta0\Winlogon                    128              7.4

A reboot of the server allows both the Windows Services and the IIS App Pools to function correctly, but only for a short period of time. (Minutes to an hour or so.) This suggests it is some kind of memory pressure (or other cummulative process) that's causing the issue.

I attempted to allow the processes to use the shared desktop heap as described here:


But this resulted in the WWW Publishing Service failing to start at all, so I had to roll back the change. Futhermore, the fact I'm not seeing heap pressure makes me think something else is going on anyway.

As a sanity check, I also used SysInternals Process Monitor to see if I was getting any file or registry access denied errors, and I saw none.

Any help would be greatly appreciated.

  • 1
    I don't have an answer, but have you tried: installing your app on a different (preferably clean) server? Also, is it possible to run your application under the default accounts (localservice)? If you are able to use localservice, how does your app behave? – chue x Dec 31 '12 at 17:07
  • A clean server works fine, but that's not an option for this deployment. There are some compatibility issues with running as localservice or other built in accounts. I can fix those, but would rather fix the root cause than work around in with a special case change. – RMD Jan 3 '13 at 15:03
  • If a clean server works, then you need to provide more info on what else is on the machine. We ServerFault readers can only guess what is on there. – chue x Jan 3 '13 at 15:43
  • What are you looking for, exactly? – RMD Jan 11 '13 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.