We've recently moved away from using a login script to map network shares and are now mapping via group policy preferences. This has been working great except I recently discovered that when our laptops are away from the domain the drive mappings are causing slow logins. It looks like every drive that is mapped adds about 15-20 seconds to the logon time. This is acceptable for users that only have a few mappings but for those that have 5 or 6 mappings the time is excruciatingly slow. Does anyone know an easy way for the mappings to only apply when clients are on the domain? Or if that's not possible is there a way to decrease the time it takes for the drive mappings to attempt to connect to the remote network share?

Any ideas would be greatly appreciated!

  • Seems to be the obvious solution is switching back to using login scripting – mdpc Dec 21 '12 at 22:29

I have seen the problem that you are experiencing - this occurs if you use the "Always wait for the network at startup". I always disable "Always wait for the network at startup" for laptops for this reason (it makes the startup experience on domain joined laptops much more bearable). Some options to consider if you would not like to disable "Always wait for the network at startup" are:

  1. You could try to do a file path condition check in GPP to see if the server path exists and only then attempt to map the printers if the file path is found.

  2. Are you using the "Update" option or "Replace" option? If you are using the "Update" option, note that it will not actually "update" your path if it changes (this is "by design"). So if you are using "Update", since it will not actually update the path anyways, here are two more options:

a. You may want to consider using "Create". This way, it only creates the drives if they are not present and hence may not take as much time on subsequent logins.

b. Or, check if the drive already exists, and if it does, then do not attempt to map it again. You can check if the drive is mapped by looking at "HKCU\Network\" (this only applies to persistent mappings).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.