So the setup looks like this:

There is a main WLAN-router/modem which is connected to the internet and serves the lower floor with WLAN. Now upstairs I have a second WLAN-router/modem (I will call it router two from now on). A normal ethernet cable is plugged in in router two in one of the four ethernet ports and also in one of the four ethernet ports in router one. Since I don't want router two to act as a router but rather as an WLAN access point I set the routing mode to bridge in the admin interface. I did also disable it's dhcp server.

Now when I connect to router two via WLAN I get a correct IP (in the range of router one's dhcp configuration) and I can also ping router one for about 5 seconds. But then the connection seems to be lost. The strange thing however is that I can ping from a computer connected to router one onto the computer at router two but not in the other direction.

Edit: Next step

I had another WLAN router laying around and tried the exact same thing and it worked. It is a different model so I think it has something to do with how the router routes I guess. Now the problem is that this router which is working is pretty old and therefore has some undesirable effects like low range. So now that I know that its a problem of the router and not of the general setup do you have any ideas what could be the problem with the other router? I can still ping from router one all devices which are connected to router two but can not ping from the devices connected to router two ... not even onto the first router. Also ping to the Google DNS won't work so it's not a DNS problem. Any ideas?


  • Non-working router: Zyxel P-660HN-F3Z with ZyNOS Firmware Version: 3.70(BJQ.1) | 04/22/2010 DSL Firmware Version: Amazon_se_ADSL 21/9 8:54
  • Working router: LinkSys WAG54GS 1.1

When using devices that need to be managed such as routers/access points, you should assign them a static IP address outside of the IP range dedicated to DHCP.

Make sure that the computer connected to Router1 does not have a firewall or security rules preventing responses to ping(ICMP) traffic. You also want to check this on the computer attached to Router1 which is not responding to pings.

When router2 starts to drop pings to Router1, you want to see if the computer connected to Router2 can still ping out to the outside world such as google.com or DNS Servers). If the computer can ping to the outside world but not Router1 or any computers attached to Router1 then there is most likely some firewall or security measures in place that is not allowing ping replies.

  • I tried ping to the Google DNS Servers but that doesn't work either. Could it be something specific to the model of the router (Zyxel P-660HN-F3Z) – Nicholas Dec 22 '12 at 12:34
  • For the sake of discussion lets call the new working router, Router3. Are you saying that Router3 can ping the google DNS servers and the computers connected to Router1? – Damainman Dec 22 '12 at 13:13
  • Yes. My computer connected to router 3 gets a valid IP address from router 1 and can connect to the internet and all other computers on the network. – Nicholas Dec 22 '12 at 13:22
  • Have you tried restoring Router2 to factory defaults or viewing the logs to see if any errors display when the ping connection stops? I went over the Manual and most of the security features are disabled in bridge mode so that shouldn't be the issue. If it is set to bridge mode then there shouldn't be any issues related to routing. Have you tried changing the encapsulation you are using for the bridge? (PPPoA or RFC 1483). When the pings drop can you verify the computer still has the proper IP and connection? Do any of the status lights or link lights on the router change when pings drop? – Damainman Dec 22 '12 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.