Like the title says I can't Windows Deployment Services working. The client laptop has an ethernet IP address of On the secondary DHCP server I've set option 60 to PXEClient, option 66 to the IP address of the WDS Server and option 67 to the boot file I'm trying to load. I've tried reseting the bootfile back to wdsnbp.com and pxeboot.com and neither work. Any ideas what I could be doing wrong?

Thank you.

This is my NETSH DHCP SERVER optionvalue all output

netsh dhcp server > show optionvalue all

    DHCP Standard Option :
    General Option Values:
    OptionId : 6
    Option Value:
            Number of Option Elements = 2
            Option Element Type = IPADDRESS
            Option Element Value =
            Option Element Value =
    OptionId : 81
    Option Value:
            Number of Option Elements = 1
            Option Element Type = DWORD
            Option Element Value = 21
    OptionId : 66
    Option Value:
            Number of Option Elements = 1
            Option Element Type = STRING
            Option Element Value =
    OptionId : 60
    Option Value:
            Number of Option Elements = 1
            Option Element Type = STRING
            Option Element Value = PXEClient
    OptionId : 67
    Option Value:
            Number of Option Elements = 1
            Option Element Type = STRING
            Option Element Value = boot\x86\wdsnbp.com

This is a portion of a single frame of wireshark output from the WDS server.

Bootstrap Protocol
    Message type: Boot Reply (2)
    Hardware type: Ethernet
    Hardware address length: 6
    Hops: 0
    Transaction ID: 0x16874338
    Seconds elapsed: 0
    Bootp flags: 0x0000 (Unicast)
    Client IP address: (
    Your (client) IP address: (
    Next server IP address: (
    Relay agent IP address: (
    Client MAC address: HewlettP_49:55:03 (a0:b3:cc:49:55:03)
    Client hardware address padding: 00000000000000000000
    Server host name not given
    Boot file name: boot\x86\pxelinux.com
    Magic cookie: DHCP
    Option: (53) DHCP Message Type
        Length: 1
        DHCP: Offer (2)
    Option: (1) Subnet Mask
        Length: 4
        Subnet Mask: (
    Option: (58) Renewal Time Value
        Length: 4
        Renewal Time Value: (900s) 15 minutes
    Option: (59) Rebinding Time Value
        Length: 4
        Rebinding Time Value: (1575s) 26 minutes, 15 seconds
    Option: (51) IP Address Lease Time
        Length: 4
        IP Address Lease Time: (1800s) 30 minutes
    Option: (54) DHCP Server Identifier
        Length: 4
        DHCP Server Identifier: (
    Option: (3) Router
        Length: 4
        Router: (
    Option: (6) Domain Name Server
        Length: 8
        Domain Name Server: (
        Domain Name Server: (
    Option: (15) Domain Name
        Length: 16
        Domain Name: office.lbox.com
    Option: (60) Vendor class identifier
        Length: 10
        Vendor class identifier: PXEClient
    Option: (66) TFTP Server Name
        Length: 10
        TFTP Server Name:
    Option: (67) Bootfile name
        Length: 22
        Bootfile name: boot\x86\wdsnbp.com
    Option: (255) End
        Option End: 255
  • Are you using a Cisco switch by any chance? If so, make sure Portfast is enabled.
    – Ryan Ries
    Commented Dec 26, 2012 at 20:51
  • We are. I'll check right now. Commented Dec 26, 2012 at 20:57
  • Its seems like Portfast is enabled on a per port basis. If so do I only need to enable it on the servers port or do I need to enable on the port I'm using to image the client? Commented Dec 26, 2012 at 20:59
  • I was guessing because I've had that issue in the past. PXE and WinPE actually grabs two IP addresses from DHCP in rapid succession, which can fail on certain switches and enabling Portfast has solved that problem for me in the past. But yours might not be the same problem.
    – Ryan Ries
    Commented Dec 26, 2012 at 21:01

1 Answer 1


We have two internet connections DHCP uses router and Servers use When I switched the Gateway IP on the WDS server to everything worked just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .