I have recently (today!), moved my SVN repository to my own server.

I am having trouble checking out from my new repo and also updating my current working copy to use my new repo (which is a svnsync copy from my old repo), I did this by using:

svn switch --relocate /old/repo/path /new/repo/path

This worked as expected and threw a common uuid error. I first got an error svn uuid's dont match, so I updated the uuid file in the svn repo config (repo/db/uuid) to reflect the old uuid. This got rid of that error.

Everything below are my issues, I can't do anything with my new repo (I want to change my old working copy to use my new repo (which I created then svn synced from my old repo to new). So the only difference is the uuid (which I manually changed), the revision's are exactly the same (nothing added or removed).

Next, I tried to checkout a new Working copy of my repo:
(First make new dir, and try to checkout new repo):

SVN checkout Error:

# Error after trying to checkout new working copy
# 'svn co http://svn.mydomain.com/repo1 .'
svn: E175002: Server sent unexpected return value (405 METHOD_NOT_ALLOWED) in response to REPORT request for '/newtbg/!svn/me'

SVN up Error: (same error as above)

# Error after 'svn up'
svn: E175002: Server sent unexpected return value (405 METHOD_NOT_ALLOWED) in response to REPORT request for '/newtbg/!svn/me'

SVN commit -m "commit test"

# Error after ' svn commit -m "test" '
svn: E175002: Server sent unexpected return value (500 Internal Server Error) in response to POST request for '/newtbg/!svn/me'

It seems that I may have set something up wrong?.

You can view my vhosts config setup here: vhost setup for multiple SVN repositories on same server

To Summarize...!
I have a new repo svn sync'd from my old repo. I relocated the working copy URL to my new svn repo url (svn sw oldUrl newUrl), then I updated the UUID to match the old repo to get rid off the UUID's don't match error.

Update: Forgot to mention, I can access my repo through the browser using the repo URL, I am displayed with the revision number & repo files, so it does work!! (i think! :S)

added my vhosts.conf:

<VirtualHost *:80>
        ServerName svn.mydomain.com
        ServerAlias svn.mydomain.com
        ErrorLog /var/www/html/log/svn.mydomain.com-log
        <Location "/" >
            DAV svn
            SVNParentPath /ebs/svn/
            SVNListParentPath on
            AuthType Basic
            AuthName "Private - Repositries"
            AuthUserFile /ebs/svn/login/svn-auth-conf
            Require valid-user
  • have you granted the good rights for svn user in your server? – artragis Dec 27 '12 at 15:50
  • currently, everything is owned by ec2-user (all svn repos), I changed this to apache:apache and it didn't make any difference, I am using Amazon EC2 linux AMI. Not sure if this is right? – Anil Dec 27 '12 at 15:53
  • 1
    1/ You must to read Apache error-log for real error detection (and maybe show errors here) 2/ You fix UUID in the wrong style, correct way is svnadmin setuuid command (JFYI, unrelated to mentioned errors) 3/ 405 error may means access-rights problem of your authenticated svn-user for reading repo – Lazy Badger Dec 27 '12 at 16:09

Figured it out!.. The issue was that I was behind a load balancer (which I was planning to get rid of anyway). So I removed my EC2 instance from the load balancer, and everything started to work again!..

So if you having these issues, make sure your not behind a Amazon load balancer (or find a workaround).

All this time, I thought this was a SVN issue, it turned out to be something to do with the server. My SVN setup was fine!.

After I fixed this issue, I accidentally committed to my old repository!, Then when I tried to commit to my new repositry, It was out of sync. So I had to svnsync sync file:///path/to/repo to get it all in sync again!.

All in all, great learning curve with SVN (new repo, syncing, errors & finally success!!), and hope this saves someone abit of time!!

Everything works great now! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.