5

Since today Debian gives an error: ifup: couldn't read interfaces file "/etc/network/interfaces"

If I look up the interfaces file I see the following:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dchp

allow-hotplug eth1
iface eth1 inet dchp

I'm running Debian in a Virtual Box; eth0 is a NAT and eth1 is a host-only adapter I also tried it with an ethernet cable plugged in, but that didn't make a change.

How can I get rid of this error?

Thank you in advance,

Remco

  • Can you put strace -fv ifup eth0 to pastebin.com or a similar site? – ott-- Dec 28 '12 at 16:05
11

You'll probably kick yourself, but you've got the same typo on two lines. It should be iface eth0 inet dhcp not dchp.

ifup and ifdown will break if they can't parse the file.

0

I had the same problem with static ip configuration In my case said /etc/network/interfaces:2: misplaced option ifup: couldn't read interfaces file "/etc/network/interfaces" lo que hice es que colocar ( # ) en las linea ( 2 )
example 1-- #auto lo 2-- #iface lo inet loopback

And raise the network again with the command ifup eth0

I hope someone will use this reference on the line that poorly written

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.