I'm trying to install Debian on my macbook without using rEFIt. Fedora worked just fine before, and Debian installs allright, but it uses grub2, and the EFI just won't see it. I've tried the expert install, but it doesn't give me the option to choose which grub version I want.

So, how can I install Debian Lenny using grub 1 instead of grub 2?

UPDATE: I just installed Ubuntu and it worked, so the problem is really grub2. Since I don't want to run gnu/linux with 'windows mode on', I would still like to install Debian, so any thoughts are appreciated.

Another Update: I finally got it working, and posted an answer, since it's been said many times (in podcasts, etc) that's the way to proceed in cases like this.

4 Answers 4


I don't understand what the problem with rEFIt is ?

You could just install the system with no boot loader/ignore that it doesn't work.

That leaves you with how to get a boot loader onto the system.

  • You could follow These instructions on how to get grub2 working on efi on a macbook.
  • You should be able to use the grub version 1 .deb file from Ubuntu on debian.

Why don't you try to install Debian like you would normally, then popping in a live CD that uses GRUB 0.97 (Ubuntu maybe) and then install grub 0.97. (backup your menu.lst first)

# grub-install --root-directory=/dev/sda

Just make sure that /dev/sda is the DISK you are booting from. Afterwards you can put back your menu.lst (although I don't know if there are big syntax and options differences between 0.97 and 2.

  • I've tried that, but I couldn't get it to work. The grub-install says it couldn't read my /boot/grub/stage1 file... Jul 27, 2009 at 0:00

I finally got it working. I did it by following the instructions in this wiki.

More specifically these instructions.

Basically, all you have to do is skip the grub instalation, drop into a shell (with Ctrl+Alt+f2) and type:

chroot /target
aptitude install refit
gptsync /dev/sda

Then you just resume the instalation process and install grub as usual. Worked very well for me.


Boot from the cd, & mount the root partition on the /mnt
grub-install --root-directory=/mnt /dev/sda OR /hda.
This should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.