I set up a new server 2012 Standard box on the LAN and created a new domain.

I've set the users profiles to roam. I'm trying to log on to the domain with one of the users I set up. The computer I'm using has been joined to the domain.

When I try to log in, I get a temporary profile. I can not get it to use the roaming profile.

The "error log" says: DETAIL - The system cannot find the file specified. The event ID is 1521 which leads to several unhelpful articles with a google search.

  • I don't have any profiles in registry with .bak as might be found when searching for that event ID.

  • I have tried copying the old roaming profile to the new server.

  • I set up the folders via this technet article: http://technet.microsoft.com/en-us/library/jj649079.aspx

  • I deleted all profiles in the registry.

Any ideas/pointers as to where to look would be much appreciated.


enter image description here

  • Perhaps you could give a brief explanation of your goal(s). For instance, why are you creating a new domain rather than simply adding the new DC to the existing domain? – mfinni Jan 3 '13 at 21:16
  • Because I want to run the domain with 2012 functionality; the old one is 2008 r2. the goal is to have users use roaming profiles. – stormdrain Jan 3 '13 at 21:17
  • Ancillary - in essentially every case, you really do want to install the new DC into your current domain, upgrade the domain, and perhaps (if necessary) retire your old DC. As N00b says, you've set yourself up for a lot more work. Also, you said that you copied the old roaming profile? That means the users in the old domain are already using roaming, so you've already achieved that goal in the old domain, right? Don't make this needlessly hard on yourself. – mfinni Jan 3 '13 at 21:30
  • It is a small shop and I wanted to start with a clean slate. The old domain is littered with learning-type fudgery and I thought it'd be a worthwhile experience to learn by doing (again). The user I've been trying to log in with was/is roaming on the old domain. – stormdrain Jan 3 '13 at 21:33

This is the error log from the workstation? Then try it from a different workstation (also in the new domain), same user. See if the problem still occurs. If it doesn't, it's something wrong with the first workstation.

If it does recur, then either both workstations are misconfigured (not impossible - what OS is on the workstations?), or the user profile is misconfigured.

Put a screenshot of the user's configuration in the new domain, the tab for roaming profiles, here in your question, so we can see the actual config.

OK - I see that you've done that. Once the user is logged into their workstation, can they browse to that exact path? Does the name d2.coolcorp.local resolve to the correct IP of the 2012 DC? Does that user have the correct Share (on the hidden share) permissions and NTFS permissions on everything in that path?

  • The tab for roaming profiles? In server 2012? All I set on the server (besides setting up the folders) was in the Active Directory Admin center > OU > User > profile where I set the path to the Share created via the technet article. Likely I don't recognize what you mean as I'm not used to the new UI yet. I will try another machine tomorrow. Thanks. – stormdrain Jan 3 '13 at 21:55
  • I am talking about the user's setting for roaming profile in AD, yes. Post that screenshot. – mfinni Jan 3 '13 at 22:13
  • Edited my answer with more pointers - workstation OS, DNS, permissions questions. – mfinni Jan 3 '13 at 22:29
  • OK thanks. I checked the full path from another machine and it worked fine. But from the machine I was logging into, it didn't resolve. I changed the profile setting on the server and we're good to go. Thanks! – stormdrain Jan 3 '13 at 22:32
  • You have learned a vital lesson - name resolution is one of the first places you should look for problems in AD, because 1) they're common and 2) they're easy to check. – mfinni Jan 3 '13 at 22:36

This appears to be an issue with the encryption.

If on the share > settings I uncheck Encrypt Data Access, the access denied error goes away. It's possible that it is due to the local secpol on the client which had to be changed to work around another issue with smb sharing. The setting that was changed was Network client: digitally sign communications (always) > disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.