I am running an Apache2 HTTP server off of a Debian-based box, connected through a D-Link DI-524 Router.

Network Setup: Modem -> DI-524 Router -> Debian Box + Laptop

I am able to access the HTTP server via the local network by its local IP address or its external IP address using device: Laptop.

When I try to access the HTTP server via an external network by its external IP address, the Apache2 server does not receive the request according to my logs.

What I have tried:

I had already set a Virtual Server on the router up to forward HTTP to the device, so I tried putting the device in the router's DMZ.

No luck either way.

I am new to this level of networking and would sincerely appreciate any help you may provide.

Please let me know if you need further information to diagnose my problems.

  • 1
    Could your ISP possibly block web hosting? If so, you'll have to use a non-standard port (such as 8081). Sites like CanYouSeeMe.org can help you determine this – quentinxs Jan 4 '13 at 7:20
  • BLAST! I'd already used a servuce like CanYouSeeMe earlier, but I'm so tired that I didn't put two and two together and assumed my configuration must still be wrong. Bah! I should have thought of this. I know better. Thank you for pointing this out! According to a quick search Cox Cable does block port 80. I know how to fix this no problem. Thank you for your comment! Feel free to add it as an answer and I'll accept it. – Zéychin Jan 4 '13 at 8:14

Some ISPs block web hosting. If so, you'll have to use a non-standard port (such as 8081). Sites like CanYouSeeMe.org can help you determine if this is the case.


This guide could help you:


The main things to check:

Your Private port should match the port configured in your apache configuration file. The directive to look for is

Listen 80

or any variation of that.

If you want this server to be easily accessible it is a good idea to keep the Public port at 80.

The Private IP should match your debian box internal ip, such as or whatever your ip address is.

Hope it helps.

  • +1: While this was not my problem (see qsheets's comment on my question), this was a good answer that may help others. – Zéychin Jan 4 '13 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.