I'm trying to install openstack on RHEL 6.2. Following installation guide from openstack.org, I'm using the command:

yum install openstack-nova openstack-glance

After resolved many dependencies, I got the final error:

Error: Package: openstack-nova-compute-2012.2.2-1.el6.noarch (epel)
       Requires: libvirt >= 0.9.6
       Installed: libvirt-0.9.4-23.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2)
           libvirt = 0.9.4-23.el6

I installed libvirt 0.9.4 from the RHEL 6.2 DVD, but it seems I have to upgrade libvirt 0.9.6. How to do the upgrade? Or where can I download libvirt 0.9.6 rpm? Or can I use yum to upgrade libvirt?

2 Answers 2


Have you tried

 yum upgrade libvirt

If this does not find the version of libvirt that you want, then you might be out of luck for the easy approach as downloading or adding this package individually via rpm might cause incompatabilities in the RH system which could make contacting RH support difficult.

If the yum upgrade does not work, I'd be inclined to contact RH support and push them to fix the incompatibility between the packages that they support that do not interoperate. This would allow RH support staff to continue to support your system.

  • I tried yum upgrade libvirt, it said "No packages marked for update".
    – TieDad
    Jan 5, 2013 at 3:38
  • Then go contact RH support. Since these are all RH produced packages, they must be responsible for interoperation between other packages.
    – mdpc
    Jan 5, 2013 at 3:39

Update to RHEL 6.3 first. This contains libvirt 0.9.10, which will satisfy the dependency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.