0

Since I am having problems with rhodecode (db problems when upgrading) I reverted rhodecode to an old version (1.3.6->1.5.1->1.3.6). Beaker is a dependency and should have been reverted to 1.6.3 but sticks to 1.6.4 - with no error message either during the Rhodecode downgrade or a manual attempt.

Manually trying to downgrade yields

server:~# pip install beaker==1.6.3
Downloading/unpacking beaker==1.6.3
  Downloading Beaker-1.6.3.tar.gz (52Kb): 52Kb downloaded
  Running setup.py egg_info for package beaker
Installing collected packages: beaker
  Found existing installation: Beaker 1.6.4
    Uninstalling Beaker:
      Successfully uninstalled Beaker
  Running setup.py install for beaker
Successfully installed beaker
Cleaning up...
server:~# pip freeze
Babel==0.9.6
Beaker==1.6.4
FormEncode==1.2.4
Mako==0.7.0
Markdown==2.1.1
MarkupSafe==0.15
Paste==1.7.5.1
PasteDeploy==1.5.0
PasteScript==1.7.5
[...]

So I am still at 1.6.4. Also dependent Rhodecode still stumbles upon this.

How to I downgrdae to 1.6.3? (Running on Ubuntu with Python 2.6.6.)

1

It happens rarely that mixing easy_install and pip can lead to some odd issue.RhodeCode can work with 1.6.4, i recommend removing file requires.txt from RhodeCode.egg-info located in site-packages of your python installation or virtualenv directory

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.