I just did a clean install of Ubuntu Server 9.04 in Virtual PC on the Windows 7 RC, and it seems to be having a bit of an issue with the virtual machine's display adapter. I've tried setting a VGA flag in the GRUB configuration to no avail. This is a guess, but I think it has something to do with the color console mode that gets enabled by default at boot time. The system starts booting just fine (i.e. the console looks "normal" when I'm asked to enter an LVM passphrase, etc.), but then the display goes wonky after a few seconds and I end up with this. Typing commands in bash works just fine: it's not like the system is frozen or anything, I just can't see anything that I type. The console looks exactly the way it does in the image below.

alt text


Virtual PC doesn't support 24bit colours, you must manually set X to use 16 or 32bit colours.

  • Thanks! Reconfigured Xorg (editing files manually sucks when you can only see 6 lines at a time!) and now everything is working great in 16-bit color. Jul 27 '09 at 20:57

It looks like the fancy graphical startup doesn't like the VM's framebuffer (so you might have hassle with X too until you install the right X server, I'm guessing VPC provides an appropriate one if it is needed).

To disable the graphics start, remove "splash" from the relevant line in grub's menu.lst. That should get you at least as far as X starting before you hit more graphical problems.



When I installed ubuntu server 9.04 I had the same problem but I added "vga=791 noreplace-paravirt" to the end of kernell line in /boot/grub/menu.lst and resolved this issue.


This fixed it for me (under Vista but I assume it will work for Win7):

edit /etc/modprobe.d/blacklist

add the line”blacklist s3fb”




use ALT+F6 to get a console and login. experiment with different numbers in "stty rows 6 columns 45" to get a visible screen with what can be drawn in virtual pc. use a text editor to modify grub. note nano doesn't work well with only 6 terminal rows. if you're using a fresh install of ubuntu 9.10, grub has changed and you will need to edit "/etc/default/grub" to change the value for GRUB_CMDLINE_LINUX_DEFAULT="vga=791 noreplace-paravirt". also uncomment GRUB_GFXMODE=640x480 . run sudo update-grub . reboot. note that vga=791 is depreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.