55

I am trying to install .Net 3.5 on Windows Server 2012 and it constantly keeps failing. I am using "Add or Remove Features" and my Internet is already there. I've read that if alternate source couldn't be found, the installer tries to download online and installs it from there. However, it's not working. This is the screenshot that I keep seeing:

enter image description here

Please suggest what am I missing?

Edit:

I already tried using dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /all but I do not have the source disk with me. I want to download it online.

  • 3
    If you want to download and install it, you must write: dism.exe /online /enable-feature /featurename:NetFX3 /all (without specifying the /Source) – Searush Feb 1 '14 at 12:20
  • 2
    @SEARAS did not work – MickyD Sep 18 '14 at 2:38
  • If you, like me, have tried all of these and still nothing, try disabling UAC. I had to end up mounting an ISO and providing alternate source, and disabling UAC to get it to install properly – Cougar9000 Oct 9 '14 at 19:33
  • I've tried several solutions, but nothing works. My solution is this: smart-arab.com/2013/12/… – user320239 Nov 3 '15 at 17:52
  • 2
    After spending hours on this nightmare I found this: 404techsupport.com/2012/11/… – user328556 Dec 23 '15 at 13:38

11 Answers 11

65

This behavior can also be caused by a system administrator who configures the computer to use Windows Server Update Services (WSUS) instead of the Microsoft Windows Update server for servicing.

http://support.microsoft.com/kb/2734782

This worked for me. Windows has to download the 3.5 installation files, but the server is configured not to use Windows Update (common for managed servers), but WSUS. The above article describes how to fix this. In a nutshell:

  1. Start the Local Group Policy Editor or Group Policy Management Console (WIN+R and type gpedit.msc).
  2. Expand Computer Configuration, expand Administrative Templates, and then select System.
  3. Open the Specify settings for optional component installation and component repair Group Policy setting, and then select Enabled.
  4. Select the Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS) checkbox. options to enable

  5. Make sure Windows Updates Service is set to Manual or Automatic to apply this fix. Our default images are set to disabled, and the issue continued until that seemingly obvious change was made.

  • 6
    Based on the OP's comment, this appears to have been the correct answer. – Michael Hampton Apr 5 '14 at 4:32
  • 2
    Did not work for me, it was already on this setting – MickyD Sep 18 '14 at 2:40
  • This worked for me. Many thanks, you made my day ! – Alexandre Danault Dec 8 '15 at 13:54
  • 1
    I tried your suggestion and that solved half of the problem, the other 50% were solved through setting the proxy for Windows Update using command prompt and netsh http winhttp set proxy X.X.X.X:80, after that .NET Framework could be installed and Windows Update worked again. – SaschaM78 Jun 28 '16 at 8:11
  • 1
    In my case, it was not configured ( all option grayed out) but after manual setting - installation works! So it is default which is set, but traditionally, not documented... – kakaz Feb 8 at 6:53
10

Step 1: Uninstall any of these updates in: Control Panel -> Uninstall a Program -> View Installed Updates.

  • KB2966826
  • KB2966827
  • KB2966828

Step 2: Then, retry installing the feature using the GUI (Server Manager), command line (dism), or PowerShell (Install-WindowsFeature)


Additional information on enabling features


Method 1: Using GUI - Server Manager

Server Manager -> Add Roles and Features -> Role-based or feature-based installation -> Select Server -> Features -> .NET Framework 3.5 Features

Method 2: Using Command Line - dism

dism : Using local installation media/Windows update/WSUS

dism /online /enable-feature /featurename:NetFx3 /all

DISM: With a local 'Alternate Source'

dism /online /enable-feature /featureName:NetFx3 /all /limitAccess /source:drive_letter:\sources\sxs

Please replace drive_letter with the drive letter of your local drive where the installation files reside

DISM: With a remote 'Alternate Source'

dism /online /enable-feature /featurename:netfx3 /all /LimitAccess /source:\\share_name\sources\sxs

Please replace share_name with the the UNC of the shared location where the installation files reside

Method 3: Using PowerShell

PowerShell: Using local installation media/Windows update/WSUS

Install-WindowsFeature –name NET-Framework-Core

PowerShell: With a local 'Alternate Source'

Install-WindowsFeature –name NET-Framework-Core –source x:\sources\sxs /source:drive_letter:\sources\sxs

Please replace drive_letter with the drive letter of your local drive where the installation files reside

PowerShell: With a remote 'Alternate Source'

Install-WindowsFeature –name NET-Framework-Core –source \\share_name\sources\sxs

Please replace share_name with the the UNC of the shared location where the installation files reside

Helpful Resources:

http://www.askvg.com/fix-0x800f0906-and-0x800f081f-error-messages-while-installing-net-framework-3-5-in-windows-8/

http://blogs.technet.com/b/askcore/archive/2012/05/14/windows-8-and-net-framework-3-5.aspx

  • This would be a much better answer if it had a real explanation. Simply linking to an external site is not really useful. – Michael Hampton Oct 2 '14 at 21:49
  • Answer has now been updated with additional information. I faced this issue and just resolved it. Hope it helps someone else too – slayernoah Oct 3 '14 at 20:34
  • an easier way serverfault.com/a/706709/157373 – Jason Pyeron Sep 18 '17 at 0:16
5

After trying to install .net 3.5 on Windows Server 2012 for 3 days, I have finally managed to do it.

The key for me was to check the installed windows updates for KB2966826, KB2966827 and KB2966828. I had KB2966827 installed and after removing it, I could install 3.5 via Server Manager.

See this article http://www.askvg.com/fix-0x800f0906-and-0x800f081f-error-messages-while-installing-net-framework-3-5-in-windows-8/

  • 1
    That worked for me, for some reason Windows install this update even if you haven't installed .net 3.5 on your system, making it impossible to install. More info: support.microsoft.com/kb/3002547 – ojovirtual Sep 24 '14 at 8:56
4

When running netfx3 feature enable, it stopped ad 66.6%.

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All

I verified my proxy settings in Internet Explorer > Connections.

I changed my group policy settings to enable optional components

Computer Configuration > Administrative Templates > System > 

Enable "Specify stettings for optional component installation and co...."
Check the check box "Contact Windows Update..."

After all this, I finally managed to install .NET Framework 3.5 in windows 2012.

Hope it helps!

3

In Internet Explorer, go to:

  • Tools
  • Internet Options
  • Security
  • Internet
  • Custom Level
  • Downloads | File Download = Enable

Run PowerShell as an Administrator Enter this, to download and install .net 3.5:

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All 

Result: PS C:\Users\Administrator> DISM /Online /Enable-Feature /FeatureName:NetFx3 /All

Deployment Image Servicing and Management tool Version: 6.3.9600.17031

Image Version: 6.3.9600.17031

Enabling feature(s) [==========================100.0%==========================] The operation completed successfully.

  • 1
    tried this but still doesn't work. It shows 100% but then says The operation is complete but NetFx3 feature was not enabled – jtate Apr 11 '17 at 19:22
2
  1. Load windows server 2012 DVD to your DVD Drive. then go to this path

    yourDVDLetter:\sources\sxs
    
  2. Copy the path from windows explorer address bar.

  3. Open server manager as you did and try again add role and feature and server role then feature and select .net framework 3.5.
  4. Here before you install just click on specify an alternative path
  5. Now you can paste the address that you just have on your clipboard to path textbox.
  6. Finally click on install button and after a few minutes, .net framework is successfully installed on your server.
1

I have tried everything suggested all over net - but nothing worked since I didn't have source disc. Luckily, I eventually remembered Web Platform Installer - download it, find .NET Framework 3 - install:

http://www.microsoft.com/web/downloads/platform.aspx

1

note: the standard installation of .net3.5 will point to 'windows update' for the install. IF your server is set to do its update lookup through WSUS, this will fail.

backup your registry, and try the following: http://aaron-kelley.net/blog/2014/04/remove-wsus-client-settings-and-revert-to-using-the-default-microsoft-update-servers/

after this, perform the feature install as per normal (after restarting the 'windows update' service.

worked for me :)

0

This is known issue which is well documented in actionable KB 3002547 "You cannot enable the Microsoft .NET Framework 3.5 feature on Windows Server 2012 R2, Windows Server 2012, Windows 8.1, or Windows 8 after you install security update 2966827 or 2966828" and also described in details in related MS PFE blogpost "Attempting to Install .NET Framework 3.5 on Windows Server 2012 R2 Fails with Error Code 0x800F0906 or “the source files could not be downloaded”, even when supplying source".
If you want to use dism and pull .NET from Windows Update you should issue the following command:

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All

Source/details: Deploy .NET Framework 3.5 by using Deployment Image Servicing and Management (DISM)

  • 1
    The links to the articles are not relevant to the problem the op had. The articles describes a problem that only appeared after an update from Aug 2014. The command you have mentioned would have fixed the OP problem at the time, but doesn't resolve the condition caused by the update in your links. The MS fix for that is support.microsoft.com/en-us/kb/3005628 – Drifter104 Jun 30 '15 at 16:29
  • @Drifter104 Thanks for bringing this 3rd link :) Now we have full and up to date picture – Mikhail Jun 30 '15 at 20:11
-1

Give this command on your Comman Prompt and modify the source path section in the command to point to your windows instalation, Source, Sxs folder.

dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs

  • The OP said in his question that he already tried that and it didn't work because he doesn't have an install disk. He has also already posted an answer detailing what did work. – Ladadadada Sep 18 '13 at 11:17
-2

just enable update of windows (run->services.msc->windows Update->Right click properties->Start up type(automatic) and start the service(Running)).

Then no error will be shown on.

protected by Community Dec 23 '15 at 14:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.