0

I want to be able to automate the initial language selection and WDS auth credentials. I am guessing I can't set that in an answer file to be provided by WDS? How can I achieve this?

  • Don't tag question titles like that. There's already tags. – gparent Jan 9 '13 at 1:47
  • how should it not be tagged? – Ablue Jan 9 '13 at 3:01
  • 1
    Since you already have the windows-7 tag, it's not useful to write "[WIn7]" in the question title. – gparent Jan 9 '13 at 14:52
4

In WDS there are two unattend files. One for the install image and one for the boot image. You set the settings that you're asking about in the WinPE section of the answer file for the boot image.

  • Doesn't really address my question. I have those settings in the answer file for the boot image, but the language selection and the wds auth dont work. The drive partitioning and install image selection all work fine. – Ablue Jan 9 '13 at 3:05
  • How does it not answer your question given the details provided? – MDMarra Jan 9 '13 at 4:11
  • My Mistake. You are saying that those settings are able to be set the normal way. Thanks. – Ablue Jan 9 '13 at 5:31
0

I had this problem, strangely there are 2 places in the answer files where it is possible to set the language, one for the initial install and one for the OOBE. For the initial install I always use US (as anything else doesn't seem to work), then for the OOBE set your own country/language:

PE.xml:

<component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="amd64">
  <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
  </SetupUILanguage>
</component>

OOBE.xml:

 <settings pass="oobeSystem">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-gb</InputLocale>
            <SystemLocale>en-gb</SystemLocale>
            <UILanguage>en-gb</UILanguage>
            <UserLocale>en-gb</UserLocale>
        </component>

Hope that helps

Jim

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.