1

I have this asp.net(vb) (.net 2.0) application I'm trying to install on a 2008 server R2 virtual machine. I'm an experience web developer and bsd/linux server admin but I'm not really a windows server and have extremely limited experience with IIS - No schooling on the topic either so please treat me as if I'm an idiot when replying :) Make no assumption I know what you're talking about here.

Anyway, I've installed the IIS roll, I have the default application pool set to .net 2.0 and I have my application in the default pool. To be completely honest I'm not even sure this thing is .net 2.0 but that is what I was lead to believe. After a bunch of blood and tears I was able to get this thing to finally answer the door when I knocked on hxxp://localhost/Flex (my virtual directory / app dir).

The problem is now I'm greeted with the following parse error instead of a gorgeous blonde in a french maid's outfit (I renamed the class its looking for in this post since the original programmed used his full name as the class name):

Parser Error Message: Could not load type 'Flex.SomeClass25'.

Source Error: 

Line 1:  <%@ Page Language="vb" AutoEventWireup="false" CodeBase="CalcSeals25.aspx.vb" Inherits="Flex.SomeClass25" %>
Line 2:  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
Line 3:  <html>

I found a bunch of stuff on the net to try to get around this to no avail, when I ran across the idea of changing CodeBase= to CodeFile= at the top of the .aspx file. When I do this it appears the parser starts to actually parse the .vb file thats referenced, however it bails again, and since I'm not a .net programmer I have no idea what this means:

Compiler Error Message: BC30002: Type 'DataTable' is not defined.

Source Error:

Line 41: 
Line 42:     ''Dataset holds all contents of csv file and used for lookups and populating listboxes.
Line 43:     Dim Table1 As DataTable = New DataTable("PipeData")
Line 44:     Dim SealTable As DataTable = New DataTable("SealTable")
Line 45:     Dim Row1, Row2, Row3 As DataRow

Now I know this is a server help forum so I'm not really expecting syntax help with this, nor do I have an urge to debug this either. The problem is, is that this exact code is running on a different server just fine. There is something wrong with the way this whole this is set up / configured that is causing the issue. I'm not really sure I should be changing codebase to codefile.

The whole purpose of me doing this is that I'm porting this application to a pure JavaScript version. I need have a running local copy of the original so I can output debugging information to see what values the original app has for certain values at specific points through the execution. Any help with this is greatly appreciated! I stink at IIS/ASP so bad!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.