Router: IP:
Host OS: Windows 7(64 bit) - IP:
Guest OS(VMware): Ubuntu 12.04 LTS(64 bit) - IP:

Guest OS has a NAT and a bridged connection via VMWare.

I'm running a basic Node.js server/website listening on port 8000. Port forwarded Router with internal/external port: 8000

I can access my website on LAN(via Windows OS) but not from the any computer outside it or via the internet.

(1) Disabling Ubuntu firewall "ufw".
(2) Windows 7 firewall disabled.
(3) Problem persists even for apache2 or any other server.
Result: No change

Also external port scans(nmap on external IP) show my port 8000 to be "filtered" rather than open.
Also running the same Node.js server on port 8000 in Win 7 works fine. Port 8000 is "open".

I have tried a "lot" of online solutions for several days but no progress. Any solutions/ideas please?


You said, that you forwarded the port on the router.
But you need to forward the port from your host system to your guest system.
You can do that in the VMWare settings. Go to NAT settings (Edit > Virtual Network Settings > NAT) and edit the VMnet host. Then press the "port forwarding" button and forward port 8000 to 8000.

See VMWare support article:

| improve this answer | |
  • I'm actually using VMWare Player 5.0.1 build-894247. There are no NAT settings like in VMWare Workstation. Also ther's no "vmnetcfg.exe" either. Bu I'm using both the Bridged and the NAT network connections. – nesslersreagent Jan 10 '13 at 12:12
  • Try using Virtual Network Editor: carbonwind.net/Virtualization/VMware-Player-Networking-Options/… Or as an alternative, have a look at vagrantup.com. This is my prefered tool for webserver virtualisation for development. – lukassteiner Jan 10 '13 at 12:17
  • Ok I'll look into those right away. But do you recommend switching over to VMWare Workstation, ie- will my problem get resolved? Because I've got all my files saved on disk. – nesslersreagent Jan 10 '13 at 12:21
  • I'm not an export at VMWare, but it looks like the advantage from switching to vmWare Workstation is that you need no separat tool to edit network configuration. – lukassteiner Jan 10 '13 at 12:59
  • Alright thanks. And "vagrante" seems very interesting too. I'll try that out soon. – nesslersreagent Jan 10 '13 at 16:38

Problem solved.

I switched over to "Oracle's VirtualBox" and it works flawlessly.

It's possible to employ a virtual server either by -
(1) NAT connection with port forwarding.
(2) NAT and a bridged connection.

I used option 2 and used a static IP( for the bridged connection. The NAT connection defaults to by DHCP.

Router port forwards as, incoming port: 8000, outgoing port: 8000 and outgoing IP:

For a clear and concise tutorial, here's a good link -> http://www.howtogeek.com/122641/how-to-forward-ports-to-a-virtual-machine-and-use-it-as-a-server/

It's possible on "VMWare" too, but it's much simpler on "VirtualBox", in my opinion.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.