I'm a complete novice with MDT 2012, but I have had pretty good luck getting a deployment for Server 2008 R2.

I have a reference system, and I do a very vanilla sysprep and capture using the template task sequence with no changes.

My deployment has a few app installs and other configuration items, but nothing too exotic.

My problem is this: during deployment, after applying the system from WinPE, I perform the final reboot. At this point, the expected action is for an autologon to take place, and for the local Administrator account to run c:\Litetouch.vbs, which does some final cleanup and a few tasks that require the target system to be running.

This isn't happening on my system. And a look at the registry shows that the autologon stuff has not been set up, so it won't ever happen. It's not a matter of having an incorrect account, or a count of 0, none of the autologon registry keys are even present.

In trying to solve this (I believe it worked when I first started!) I've stripped down my deployment to a pair of task sequences that have no customization at all in either the capture or the deployment task sequences, and still no luck. So I believe that something has changed in my reference system - but I unfortunately can't roll back.

What is driving me a little nuts is that I can't tell when that autologon information is supposed to be inserted in the registry. There is code in Litetouch.wsf that appears to do it, in function PopulateAutoAdminLogon, but I can't come up with a scenario in which this function gets called. I am guessing that perhaps sysprep does it when creating the WIM, but I can't seem to find good information on that.

I've done a lot of searching on this, and unfortunately the answer space is cluttered with people who have a similar sounding but completely different problem - they want their deployed system to do an autologon, and after deployment their system comes up with the logon screen instead of doing what they want. I've seen a few people post similar problems to mine, but nobody has received an answer.

So in a nutshell: when deploying a system using MDT 2012, at what point do the autologon items from unattend.xml stuffed into the registry for use after state restore/reboot in the task sequence? And what can go wrong with that?


My problem was being caused by a sysprep failure - the rearm count on my image had quietly bounced up to 2 due to carelessness.

What's strange is that such a huge failure in the process generated no obvious red flags. I really had to dig to find the problem. The sysprep failure cascaded into a dozen other problems that were all red herrings. Working my way backwards finally gave up the answer.

| improve this answer | |

If you have SkipFinalSummary=YES in your customsettings.ini file (Rules), then you will not see the summary wizard that shows that the task sequence has completed successfully. It will only show if the task sequence fails. The Lite Touch scripts clean up the machine when the task sequence finishes, including removing autologon settings. This is explained in Michael Niehaus’s TechNet blog “MDT 2010 New Feature #15: Finish actions”.

If your task sequence is failing and not showing the summary wizard, then a good place to start troubleshooting this problem is to check the log files to see if there is a reason why the deployment failed and what errors might have occurred. The TechNet article “Understanding Failures and Log Files” should be of great assistance for this.

Last, many articles and videos that will help with MDT can be found on the Deliver and Deploy Windows 7 page of the Springboard Series on TechNet.

| improve this answer | |

MDT stores all this information in the answer file. If the execution of the task sequence fails to copy this information to your image file, try rebuilding your task sequence, its amazing how many issues in MDT can be resolved by simply recreating a new task sequence. Check BDD.log, there's always clues in that file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.