I need to find a network driver that will work in WinPE for a HP8300 SFF desktop deployment. The network device is an intel 82579LM.

I don't need someone to find a driver for me - I can handle that.

I need to find a way to determine WHICH driver (inf) file my working 8300 is using. And in my simple brain I would be able to boot an 8300 to winPE, inject the driver with drvload, connect to a network resource and get some work done.

I have tried several drivers that HP says this machine uses, none of which have worked.

In winPE assuming I have the correct driver, isn't it just 1)inject with drive load and 2) netcfg -winpe?


Ok finally figured this out. First off, you need to find the correct drivers. This became relatively easy for me as I am deploying about 50 HP 8300's and the hp site has the winpe driver pack.

Next I was creating a bootable ufd. Here is a very good guide http://technet.microsoft.com/en-us/library/cc766092%28v=ws.10%29.aspx . HOWEVER there is an instruction omitted as one user points out in the comments:

The instructions in step two leave out one important step. 
The sources directory must  have a boot.wim file.
Here is the command:
xcopy c:\winpe_x86\winpe.wim c:\winpe_x86\iso\sources\boot.wim /y

The you need to mount the image file as shown here http://www.windows-noob.com/forums/index.php?/topic/2349-guide-adding-drivers-to-a-custom-winpe-30/. After mounting the image, you can add the drivers, then when you are ready commit the image.

Finally you should copy the files to another directory OR directly to your USB drive.

  xcopy c:\winpe_x86\iso\*.* /s /e /f f:\

How did I know it was finally going to work? Generally if you boot a standard windows PE UFD, if will load wpeinit immediately - this time is took some time to wpeinit so I knew it was loading all drivers. I typed ipconfig and it showed me that I had an ip address.

I think ONE of the places I was really missing the boat was when I was mounting the image, I was pointing to the incorrect wim file. So I WAS injecting drivers to A wim file, just not the correct one. Be sure you are mounting the wim file in sources\iso folder of the original winpe files.

Another this I realized was it didn't seem to matter if I threw 10 network drivers at it - basically if the correct drivers were there it will load it. Through trial and error I started wondering that if I had the wrong drivers was it failing the first one and not attempting to load any others. This does not seem to be the case as my working UFD has several different network drivers.

I really this helps someone because I have spent far too much time trying to get it right.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.