I got a brand new workstation on Friday that I am trying to install with Windows 2008 Server (64-bit) for our development box. The workstation is an Intel i7, 6GB RAM, with 3 x HDDs (SATA) and we've got an MSDN subscription (also new, although the disk I'm using is dated May 2008).

The box was already built and had a trial version of Vista installed (presumably so that the supplier could test everything). First attempt at booting the workstation returned an error about starting Vista (I honestly forget what exactly) but choosing "last known good" got me into this Vista installation. I inserted the windows 2008 DVD and ran through the setup - I didn't note this error when it failed (although after this point I started taking notes) but I presumed it was related to moving the existing Vista files into a windows.01 folder and Setup restored the Vista installation.

So I ran setup again (booted from CD) and at the point of choosing where to install Windows I created a partition on the first drive, formatted the partition and proceeded with the install.

Windows copied the files very quickly, but expanding took a few minutes while the progress meter sat on 0%, was still on 0% when the server rebooted (unexpectedly, none of the usual Windows needs to reboot. 10, 9, 8...) but then I got

Bootmgr is missing
Press ctrl-alt-del to restart

Rebooted from CD and went into Repair. It didn't acknowledge that anything was installed on the drive but from a command prompt I could see the following folders:

Program Files 
Program Files (x86)

Those folders had subfolders, but search for .exe or .dll files I only found the setup.exe in $WINDOWS.~BT so clearly the copying/expanding isn't working.

Formatted the drive (from the command prompt), then I ran setup. This time it completed the installation ok (the copying files to hard-drive was very quick, the expanding files task only took a couple of minutes but it showed progress) and then server rebooted gracefully. All working.

Only for some reason this time it installed 2008 Server Core! I swear I selected full installation but I thought we've got a result here - it only took 7 minutes to install (core) - so I formatted the drive again, then booted from CD, ran setup. Definitely selected Standard full installation (x-64) this time, installed onto partition 1 on disk 0. Only I got the 0% expanding and then bootmgr is missing error. Inspect the contents of C: - same as before...

I've been stuck in this loop since yesterday. Is it my MSDN DVD, or something about my hardware setup? Any suggestions?

2 Answers 2


Last time I had anything similar it was a bad installation CD, though it did at least give an error message while expanding files.

  • I'm download an ISO now... Meanwhile I thought I would try installing Enterprise edition (same DVD) instead - that got to about 40% expanding files when setup rebooted (no warning) and I now have the bootmgr is missing error as before.
    – Dan
    Jul 28, 2009 at 13:26
  • In this instance it seems to be a duff DVD (disc 4454/May 2008 from MSDN) - downloaded a new iso from msdn.microsoft.com and it worked first time...
    – Dan
    Jul 28, 2009 at 15:13

A good start if you haven't already, make sure the firmware on your machine is up to date. Most of our HP ProLiant servers required a firmware update to fix specific issues when installing Windows Server 2008.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.