1

I have a SBS 2003 server running for 3 year without any problems, and few days ago it freezes during the boot.

System is using two 500 Gb drives in RAID1 (Intel Matrix 7.5)

After trying to load in safe mode, boot stops on acpitabl.dat.

First idea was that there is a problem with RAID although disk status was OK, and RAID status was Rebuild. I tried to boot with each drive, and one gives me the same problem, and the other drive is failing to load.

Took both drives out, and checked it on a different machine. One drive is dead, other is without any problems.

Returned the good drive back in SBS 2003 with changed status to Degraded, but the problem is still the same.

I also have a clean SBS 2003 copy installed on this drive (previous installation), which loads smooth and quick.

So, I believe the main problem is this installed version of SBS 2003. Did not make any hardware changes, did not make any updates (not sure about any automatic windows updates lately).

Since there are tons posts about this problem, and no clear solution, I am trying to figure how to repair SBS 2003 installation, since there are some installed programs on this installation which I cannot re-install without additional issues.

0

I had similar problem with one XP on RAID, which broke during conversion to virtual machine. It got stuck on acpitabl.dat.

What I did to fix it was to boot with Windows 2012 CD opened the console with Shift+F10 and ran chkdsk /f c:. After this, the machine was able to boot normally.

0

During one startup while debugging similar situation, BIOS POST displayed a message about RAM read-write test failure. After one half of RAM modules (consumer-grade unbuffered DDR2 DRAM) were extracted, the machine could boot Windows Server 2003 without any trouble. Thorough examination of all RAM modules with MemTest86+ in another machine revealed no error. After putting all modules back in the server, it could boot just fine; a week passed since then without further issues. So, even though the RAM modules themselves proved to be in order, the situation was clearly attributed to memory hardware — perhaps electrical contact deteriorated, or some dust got into DIMM slots. Therefore, one should consider checking RAM issues when dealing with subject in question.

For the reference, that server was also equipped with RAID (Promise FastTrack SX4100 firmware-based card with dedicated RAM not protected by ECC), which proved to be very reliable and did not display any indication of error. However, there were video glitches — the screen was filled with “$” signs instead of whitespaces, and some displayed characters were substituted with random garbage. That is why I first tried installing a discrete videocard to use instead of integrated Intel graphics. That took the video glitches out, but did not actually help with acpitabl.dat — not until I tried replacing RAM modules.

0

Sounds like corruption to me. It's unfortunate but sometimes the RAID/SAS/PERC controller will mirror the mistakes.

You should start by replacing the failed drive with a new drive of the same capacity or greater. You will then have to go into the SAS/PERC configuration utility on boot and set your new drive as a "Hot Spare" for the the array. Once set, the controller will start syncing data and the "Hot Spare" will become your secondary drive in the array.

At this point you will still have a corrupted install of SBS 2003. If you don't have a recent backup then you will have to attempt a "Repair" on the corrupted copy. I suggest this since you cannot get into the OS using safe mode or any other entry in the startup list. This means that core windows files are missing, or have incorrect NTFS permissions/Security Permissions. Boot off the SBS 2003 dvd and be sure to choose R for "Repair"

Another idea to try is to load up the clean copy of SBS 2003 and perform a chkdsk /F on the volume letter that is corrupted. Try using diskpart->list vol to get your drive letter. It will probably find bad inodes and reset some files, maybe thousands to their default security descriptors. I have ran into this myself. Not fun. Easier to move the data off and wipe clean, reinstall. Unless you have a domain controller:( then it's worse.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.