I have a pretty basic Apache two node cluster with flat files on SAN using OCFS2 file system mounted on both nodes.The website is working as expected, but I see a lot of the following messages in both servers' syslogs:

On Apache 1

[248816.701082] (apache2,62749,1):ocfs2_mknod:459 ERROR: status = -31
[248816.702187] (apache2,62749,1):ocfs2_mkdir:613 ERROR: status = -31

On Apache2

[249043.856561] (apache2,46225,2):ocfs2_mknod:459 ERROR: status = -31
[249043.858633] (apache2,46225,2):ocfs2_mkdir:613 ERROR: status = -31

There are around 6000 such lines logged every single day and the error is always about

ocfs2_mknod:459 and ocfs2_mkdir:613.

Anyone seen this before? I would really like to get rid of these error messages.

2 Answers 2


Apparently the issue was due to bad sectors(not sure how). A few days after I posted this issue, things took a turn for worse. The system complained bad sectors on the partition, then mounted only as read-only. Eventually it stopped mounting the partition completely and we had to create a new partition on SAN and restore data from backup.

The new partition worked for a while, but now one one of the two nodes, the partition is mounted read-only for some reason. I get the following error when I touch a file:

touch: cannot touch `test_file': No space left on device

On the other node it works fine though. I can read and write as usual.

After spending too much time on this issue we have decided it is not worth the effort and are now looking into alternatives - Maybe glusterfs, GFS2 or even good old NFS share to hold flat files.


I had the error "No space left on device" but there is was free space on my ocfs2 filesystem with corosync+pacemaker on suse 11 sp2

 "No space left on device"

I Solved the problem with this http://www.novell.com/support/kb/doc.php?id=7008696

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.