I have problem connecting to a Windows Server 2008 R2 with Remote Desktop Connection. Say the server name is 'hello', domain name is 'example.com', and IP is The server and clients reside in the same LAN.

Here's the scenario when connecting to 'hello' with Remote Desktop Connection from a Windows Vista:

  1. Can't connect to 'hello' with account "example\administrator". Error message is:

    This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

  2. Can't connect to 'hello' with account "example.com\administrator". Same error.

  3. Can connect to 'hello' with account "hello.example.com\administrator"
  4. Can connect to 'hello' with account "\administrator"
  5. Can connect to '' with account "example\administrator"
  6. Can connect to '' with account "example.com\administrator"
  7. Can connect to '' with account "hello.example.com\administrator"

Another thing is, some clients cannot open hello's share using '\\hello', but can open the share using '\\'.

What's going on here? Am I missing something in DNS?

  • Out of interest, why do you want to? The authentication should be \\<WindowsDomain>\<username> so why aren't you using that format? It sounds like you're confusing a Windows Domain with a network domain name. For the share, by client to you mean the PC's or the users? Have the users been given share as well as security permissions?
    – Techboy
    Jan 17, 2013 at 11:02
  • Is the server, hello, a member of an AD domain called example.com, or is it a standalone?
    – JasonAzze
    Jan 17, 2013 at 11:28
  • @JasonAzze, 'hello' is the only AD domain in example.com.
    – fxam
    Jan 17, 2013 at 13:01
  • @Techboy, like I pointed out, \\<WindowsDomain>\<username> (example\administrator) doesn't work if I connect using hostname 'hello'. So I tried a few variations and got the above result. By client I mean the PC. Yes, the users have been given permissions. It was normal before (I could connect to server using hostname and clients can access share by going to \\hello), but things started getting strange a few days ago. I don't recall any configuration changes except some automatic Windows Updates. All clients can ping \\hello with the correct IP, they just can't open \\hello.
    – fxam
    Jan 17, 2013 at 13:17

2 Answers 2


OK, I think I fixed the problem. It was two port forwarding rules in the server firewall. Removed them and the problems are gone.


First check your DNS settings on the client from which you are connecting.

Try running ipconfig /all from a commmand prompt and check which DNS servers it's using.

From there you would then need to check if the DNS server has an entry for the destination server.

As it is not resolving the name then you are most likely facing an issue where you have no DNS server defined on your client, DNS Servers(s) that do not have your destination server registered (eg. a DNS server connecting to an ISP but no DNS server for your local network etc.)

  • Thanks, 'ipconfig /all' shows that DNS points to, which is 'hello'. Pinging 'hello', 'hello.example.com' and 'example.com' from clients and hello itself all return
    – fxam
    Jan 17, 2013 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .