I've been wrestling with ApacheDS for the past 3 days and couldn't figure out what the problem is.

I've got a fresh install of ApacheDS 2.0.0-M9 on a fresh CenOS 6.3 with the latest JDK7 installed.

After first installing the downloaded ApacheDS RPM package, the service is automatically started and I can connect to ApacheDS from a remote DS Studio application and everything works fine.

The problem happens when I do a reboot. I have not touched ANY settings or played with any of the default values. I simply did a fresh install and then rebooted.

On examining the server, I can see the ApacheDS-default service is running. However, I can not connect to it from my DS Studio on a remote machine. I tried to shutdown the service, but I keep getting the following error:

/opt/apacheds-2.0.0_M9/bin/apacheds: line 418: kill: (3794) - No such process
Unable to stop ApacheDS - default

This is puzzling to me as I can clearly see the service is "running". The log files are not showing me any ERRORs, so I'm now completely at a loss.

Much appreciate any help or ideas.

Many thanks.


I'm starting to suspect this is related to a potentially stale PID file. No matter how many times I reboot, it always tells me it's trying to kill process 3794 (it never changes).

I can't seem to find the PID location of ApacheDS. I've looked inside /var/run, but no mention of apacheds there.

Any ideas?


you fix this issue by clearing the PID file, on debian the file is located under /var/lib/apacheds<version>/default/run/*.pid

remove any pid file located in that folder and you'll be good to go.

I was lead to the fix through this blog:


start ds by either /etc/init.d/apacheds start


/opt/apacheds<version>/bin/apacheds start default

  • Just a note for those who are using OS X. This PID file is in /usr/local/apacheds-X/instances/default/run/ (where default is your instance name). – jschorr Oct 1 '13 at 16:18
  • This also worked in Fedora 19 – David Brossard Dec 30 '13 at 14:16

this is probably because the user you have chosen during installation has limited access to /var/lock/subsys folder.

this folder is checked during machine shutdown to find out whether the apacheds process should be stopped(lock file with instance name should be there - in my case it is called "default").

in case it was not closed properly during restart the lock file in /var/lib/apacheds/default/run/*.pid won't be removed and would prevent application from starting up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.