I have one Ubuntu box with 2 network cards.

I am running netperf on the computer to measure performance of networking equipment, ethernet coming out of eth0 into the switch then back out into the second card eth1. Currently when I run the test it seems to be sending the traffic internally (throughput is way to fast to be external) as opposed to out the card and back in the other card. How can I configure the traffic to be sent out externally instead of internally?

I have tested many solutions I found online with no avail.


  • 1
    Could you please expand your question re: the solutions you have already tried? – Deer Hunter Jan 18 '13 at 20:57
  • Of course I can't find it now but I tried using a kernel patch that forced it externally but that didn't seem to work. I tried this as well: serverfault.com/questions/127636/… Also did not work, our situations are slightly different but using IPtalbes still resulted in a the traffic being internal. I can't figure out why that wouldn't work. – Jerrod Jan 18 '13 at 21:06

https://stackoverflow.com/questions/2734144/linux-disable-using-loopback-and-send-data-via-wire-between-2-eth-cards-of-one has interesting information about how the kernel uses the local routing table to know can be routed internally.

  1. I've named eth1, which has no wire attached;
  2. ip route show table local reveals that local dev eth1 ... src exists. Pinging works from this very machine.
  3. ip route delete dev eth1 table local makes my ping go silent.
  4. ip route add dev eth0 table local makes me receive "destination unreachable" through the local loop, but no ICMP requests on the local loop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.