I've just installed KVM on Debian 6 64 bit and have created 2 guests and booted one of them.

I can connect via VNC and I get the Debian CD boot options (text/graphical install). I have tried selecting both and in both cases I get a blank screen after that. I figure the ISO should be ok since I can get that far, so my initial guess was the VGA driver on the guest. Unfortunately I have tried changing that as well with no luck.

Here is the XML file:

    <domain type='kvm'>
        <type arch='x86_64' machine='pc-0.12'>hvm</type>
        <boot dev='cdrom'/>
      <clock offset='utc'/>
        <disk type='file' device='disk'>
          <driver name='qemu' type='raw'/>
          <source file='/var/lib/libvirt/images/vm1.img'/>
          <target dev='vda' bus='virtio'/>
          <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
        <disk type='file' device='cdrom'>
          <driver name='qemu' type='raw'/>
          <source file='/var/lib/libvirt/images/debian-6.0.6-amd64-netinst.iso'/>
          <target dev='hdc' bus='ide'/>
          <address type='drive' controller='0' bus='1' unit='0'/>
        <controller type='ide' index='0'>
          <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
        <interface type='bridge'>
          <mac address='52:54:00:01:38:4e'/>
          <source bridge='br0'/>
          <target dev='vnet0'/>
          <model type='virtio'/>
          <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    <serial type='pty'>
      <target port='0'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <input type='tablet' bus='usb'>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' listen='X.X.X.X' keymap='en-us' passwd='XXXXXXXX'/>
      <model type='vga' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>

Any help appreciated!

  • Have you tried without virtio devices? – Heis Spiter Jan 21 '13 at 13:00
  • Surely it doesn't matter at this stage, since the disk and network device have yet to be used? – James Jan 21 '13 at 13:04

For anyone who gets stuck on this, the problem was in the ISO itself. Use a different ISO (i.e. a completely different one, not just a different mirror) and it'll work.

| improve this answer | |
  • Prompted me to look more closely at my iso... Apparently I tried to run an amd64 iso in a 32 bits machine (and host OS for some reason...). – Wrikken Apr 27 '13 at 15:58

Quoting from the docs:

When you first install a Linux guest, use the "cirrus" video driver. Post installation, if you wish to have a resolution above 800x600, switch to the standard video driver.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.