0

I'm working with a colleagues setup, so I'm hoping things were setup correctly; however I'm having some issues.

When on the Puppet Master, if I run mco ping then I get a list of agents; however if I run mco puppetd runall 1 (Or any number, for that matter for concurrency) - The only agent to respond is the Puppet master.

All machines are Ubuntu 12.04 and running in AWS EC2. I can ping and SSH into all machines. Puppet runs fine normally.

Quite confused on what I'm missing here. Could someone point me in the right direction?

Thanks in advance.

0

There is a guide on installing agents @ http://projects.puppetlabs.com/projects/mcollective-plugins/wiki/InstallingPlugins

It seems you do not have the puppetd agent installed everywhere.

In any event, the best place for support of mcollective is on freenode IRC channel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.