I'm currently undergoing CCNa academy so I got a "job" from my boss to configure Cisco 871 router. Unfortunately we just finished first semester at academy so there are some things that I'm still having hard time to understand.

I managed to configure router so it connect to internet or to be exact it has internet access through another adsl modem that is in bridge mode.

Here is picture of setup


The problem is that users are not able to use internet when connected to this router. I'm able to access router through telnet ( ip but that's it.

Here is the config from router http://pastebin.com/8JaMmqdT is network that we use at work. is IP address that is assigned to zyxel adsl modem ( If I'm correct, we could have used any address here since we are connecting this directly to router ? )

Zyxel adsl modem is connected to FA4 port on Cisco router. LAN cable is connected to FA0 port and from there it goes to switch ( it's some asus switch with 50 ports).

Here is routing table

Router-Cisco#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is to network

     is variably subnetted, 2 subnets, 2 masks
      S is directly connected, Dialer1
      C is directly connected, Vlan1
     is subnetted, 1 subnets
      C is directly connected, Dialer1
     is subnetted, 1 subnets
      C is directly connected, Dialer1
     is subnetted, 1 subnets
      C is directly connected, Loopback0
      S* [1/0] via

And here is IP interface brief

Router-Cisco#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Dialer0                    unassigned      YES manual administratively down down   
Dialer1             YES IPCP   up                    up     
FastEthernet0              unassigned      YES unset  up                    up     
FastEthernet1              unassigned      YES unset  administratively down down   
FastEthernet2              unassigned      YES unset  administratively down down   
FastEthernet3              unassigned      YES unset  administratively down down   
FastEthernet4              unassigned      YES manual up                    up     
Loopback0            YES manual up                    up     
Virtual-Access1            unassigned      YES unset  up                    up     
Vlan1               YES manual up                    up  

If I ping google dns from router e.g. ping it works. If I ping www.google.com it doesn't work.
Also I'm able to access router via but if I use router as default gateway then I'm not able to access the internet.
Can anyone point me in right direction here or tell me what I missed out ?

p.s. From where is network is subnetted, 1 subnets C is directly connected, Dialer1 comming from ? I cleared router config before starting and I don't remember configuring this one or that we use something like this at work.

  • you say if you ping it works? Does this work on the client PC's to, do they reply to Not the state the obvious, but could be a DNS issue if so. – Sc0rian Jan 22 '13 at 17:11
  • Hi, No. From client PC's nothing works except pinging – Pracovek Jan 22 '13 at 17:31

You've done a lot, but there are still a few things to correct.

  • Change the IP address on your modem to something not in the range.

The modem's IP address should only be used for configuration and not for routing.

  • Ensure that ip routing has been set. (It's not visible in the running-config).

  • Remove the 3 ip routes:

Replace the first one (the default) with a route towards Dialer1 (your WAN interface): ip route Dialer1.

The second one might not even work as Dialer1 is a PPP interface. And for the last one, is on Vlan1.

  • Change the DHCP default-router:

Use the ip address of Vlan1,

  • Remove ip nat outside from Fa4:

Having it on Dialer1 should be enough.

  • Add NAT configuration:

ip nat inside source list 10 interface Dialer1 overload and access-list 10 permit

That should be enough.

You might also take a look at this configuration or this one to have a broader picture.

And regarding, it might a server address within the ISP network, pushed with PPP/IPCP.

  • Hi, this helped. Although I had to use acess-list 10 permit any. If I used then for some strange reason I didn't had internet access. Now I'm facing another thing and that is very slow connection. The connection should be around 4Mbps and I get only 0.6Mbps. I tried setting bandwith on dialer 1 but same thing persists. show interface info -> pastebin.com/7zBMaYJH show ip nat statistic -> pastebin.com/GkwpAueh and ip nat translations -> pastebin.com/rEZ6G4TT Also I tried int vlan 1 ip tcp adjust-mss 1452 ip mtu 1492 but it didnt help – Pracovek Jan 23 '13 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.