Trying to generate a key for a server.

gpg --gen-key

We need to generate a lot of random bytes. It is a good idea to perform some other action (type on the keyboard, move the mouse, utilize the disks) during the prime generation; this gives the random number generator a better chance to gain enough entropy.

and it just hangs there.

There is another error:

can't connect to `/root/.gnupg/S.gpg-agent': No such file or directory

which seems to go away after:

gpg-agent --daemon
GPG_AGENT_INFO=/tmp/gpg-4c5hyT/S.gpg-agent:1397:1; export GPG_AGENT_INFO;

#GPG_AGENT_INFO=/tmp/gpg-4c5hyT/S.gpg-agent:1397:1; export GPG_AGENT_INFO;
gpg --gen-key

but again, it hangs at "...gain enough entropy".

There are no "++++++++++++++++++++++++++++++++++++++++++"'s which from forum posts looks like should be expected as the key is generated.

I have tried reinstalling the package, but seemingly everything depends on gpg.

I've read other people having problems with this on centos 6 too (whereas centos 5 works fine).

There is nothing remarkable in /var/log/*.

Any ideas on where to go from here?


  • rng-tools is only a solution if you have an HSM, answers which recommend this will fail on systems without this. You will see a message like: Starting Hardware RNG entropy gatherer daemon: (Hardware RNG device inode not found) Oct 14, 2017 at 11:01

9 Answers 9


When the gpg --gen-key command hangs like this, log in to another shell and perform the following command:

dd if=/dev/sda of=/dev/zero

(This command basically reads from your hard drive and discards the output, because writing to /dev/zero will do nothing.)

After a few seconds / minutes, the key generation command should complete.

  • 2
    Awesome. Thank you. I can't believe I missed that part of the manual :/
    – stormdrain
    Jan 22, 2013 at 15:59
  • 2
    It would be a much better idea to grab different entropy each time. If you're system is constantly running out of entropy then something is terribly wrong with your configuration or you're using up entropy very quickly (to the point where you should have a hardware RNG). If you need more entropy on a regular basis there are valid places to simply download more, like Humboldt-Universität's Quantum RNG.
    – Chris S
    Jan 23, 2013 at 16:38
  • 30
    I actually tried this, but since I didn't have root I couldn't access /dev/sda directly. What worked for me instead was find / | xargs file Mar 15, 2016 at 22:09
  • 3
    I was more comfortable running find / | xargs file instead of dd if=/dev/sda of=/dev/zero and after a minute it was done. Thanks!
    – Lea
    Oct 16, 2016 at 7:10
  • 5
    Do you mean of=/dev/null? Feb 14, 2017 at 16:51

For a more reliable solution you could install random number generator related utilities, which will make sure that you always have enough random bytes.

yum install rng-tools

and then edit /etc/sysconfig/rngd and add EXTRAOPTIONS="-r /dev/random"

Start the service

 service rngd start

Voila and you live happily ever after :)

  • 7
    If you don't want to start the service, you can simply run rngd -r /dev/random as root once rng-tools is installed. Your key generation will take off immediately.
    – davidjb
    May 7, 2015 at 12:23
  • 2
    But that itself doesn't generate entropy.
    – Otheus
    Sep 19, 2016 at 14:18


Open a ssh session sudo apt-get install rng-tools In another SSH window open gpg --gen--key Go back to your first SSH session and run sudo rngd -r /dev/urandom Let this run till gpg generates your keys!

Then you can kill rngd sudo kill -9 $(pidof rngd)

  • 1
    IMO - quick solution :) Apr 1, 2021 at 20:24

Both comments given before are perfectly fine. But here is just my 2 cents.

The problem with RHEL/centos 6 and entropy is that they are tickless kernels. So, by themselves, these kernels don't generate enough entropy. You have to get some keyboard attached or even some mouse movement or use dd as mentioned.

rngd daemon is awesome and most commercial entities use it.

However, the best approach I have seen is use of dedicated TPM device. They are small hardware which are quite expensive. You put them and rngd utilizes random true entropy from the hardware source. As far as I know, Fujitsu has some good TPM device.

Yeah, these three methods pretty much cover the entropy part.

  • Very interesting. Thank you. As I mentioned to Chris, I will have access to an HSM soon which comes with an RNG.
    – stormdrain
    Jan 23, 2013 at 17:22

Twist on other responses but at least one liner and not root.

((find / | xargs file) &> /dev/null &); gpg2 --gen-key --batch --passphrase-file output-key.txt key-gen-options.txt

Key-gen-options contains

Key-Type: 1
Key-Length: 2048
Subkey-Type: 1
Subkey-Length: 2048
Name-Real: myuser
Name-Email: [email protected]
Expire-Date: 0

Output-key.txt contains my super secret key.

  • This worked for me as a non-root user on the machine where I had the problem. Jan 20, 2021 at 14:46

EXTRAOPTIONS="-r /dev/urandom" worked for me instead of EXTRAOPTIONS="-r /dev/random"


I've tried all the solutions, and found that haveged works the best even when others don't work (especially on a headless server that doesn't have much user input or activity).

yum install haveged

apt install haveged

It starts the haveged daemon service that will keep /dev/random full of entropy. --key-gen should complete in less than a minute.

You can verify by running cat /dev/random. Normally, it will quickly run out of entropy and pause. That's why the --key-gen hangs. But after installing haveged, cat /dev/random should provide output continuously.


How I did it:

  1. pacman -S community/rng-tools
  2. vim /etc/conf.d/rngd to add RNGD_OPTS="-r /dev/urandom"
  3. systemctl enable --now rngd
  4. gpg-agent --daemon
  5. gpg --full-gen-key

Worked even when $GNUPGHOME is set to point to a custom directory.


Switching to gpg2 worked for me.

None of the other solutions did, because of permissions issues.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .