We're setting up SmartTarget/Fredhopper in our Tridion 2011 SP1 HR1 environment and have hit a snag - hence the question!

  • CM is configured correctly and we can see the <SmartTarget addToFredhopper="true"/> entry in the package sent to the deployer.
  • Logging is configured at DEBUG level for the deployer and we can see an entry in the smarttarget log:

2013-01-23 10:46:08,148 INFO FredhopperDeployerModule - Start deploying transport package 'D:\Tridion\incoming\Zip\tcm_0-22268-66560.Content\' to Fredhopper.

  • Sadly nothing appears in Fredhopper though - the publishing queue gets stuck at the Committing Deployment phase until it eventually fails with an "exceed polling error".

Fredhopper is installed on a different server so we're using the SmartTarget Web service (non-J2EE & Tomcat) and have configured this in the smarttarget_conf.xml:


A quick check ofthis URL in a browser succesfully responds with the WSDL. We've also configured the service to a DEBUG level but no log file is ever written, suggesting the deployer never successsfully sends anything to it.


  • Fredhopper installed - Check
  • SmartTarget Web Service (Tomcat) - Check
  • Publishing - Check
  • Deployer - Configured correctly, but unable to reach the Web Service by the look of it?

Can anyone advice on next steps to check or anything obvious we've missed?


Additional information from the core log - there seems to be an unable to execute onSuccess in here, that looks a bit suspect!

2013-01-23 14:53:12,094 INFO FredhopperDeployerModule - Start deploying transport package 'D:\Tridion\incoming\Zip\tcm_0-22272-66560.Content\' to Fredhopper.

2013-01-23 14:53:12,109 DEBUG RMICacheChannelConnector - Broadcasting event finished for key: 67:17789:17791

2013-01-23 14:53:12,250 ERROR DeployPipelineExecutor - Unable to execute onSuccess event in phase: Deployment Commit Phase for transaction: tcm:0-22272-66560

2013-01-23 14:53:12,250 DEBUG DeployPipelineExecutor - Checking if transaction is completed: tcm:0-22272-66560 is false

2013-01-23 14:53:12,250 INFO DeployPipelineExecutor - Finished executing deployment pipeline for: tcm:0-22272-66560 in 17722 ms.

2013-01-23 14:53:12,250 INFO TransactionManager - Cleaning up Deployment package for transaction: tcm:0-22272-66560 and type: CONTENT

2013-01-23 14:53:12,265 INFO TransactionManager - Finished handling of Deployment package: tcm:0-22272-66560 with type: CONTENT

2013-01-23 14:53:12,265 DEBUG QueueLocationHandler - Removing from queue Deployment package: tcm:0-22272-66560 with type: CONTENT.

2013-01-23 14:53:12,265 DEBUG QueueLocationHandler - Removing exclusive lock on Deployment package: tcm:0-22272-66560 with type: CONTENT. 2013-01-23 14:53:12,265 DEBUG QueueLocationHandler - Removed exclusive lock on Deployment package: tcm:0-22272-66560 with type: CONTENT.

  • Is there anything in the log after the line 'Start deploying transport package'? Maybe a success or failure message? – Quirijn Jan 23 '13 at 12:01
  • Is that really the only line in the log file for SmartTarget? Also, when you tried the URL in a browser, did you do it from that server? (I'm thinking it could be a firewall issue) Are you sure that your configuration changes have been picked up? (You need to restart the deployer, for instance) – Peter Kjaer Jan 23 '13 at 12:03
  • We tried a couple of times now and the only entry in the log is the "Start deploying" one. No success or failure - which kind of makes sense in the context of failure in the publishing queue - it seems to never get to the web service or never gets a response. – Neil Jan 23 '13 at 12:11
  • When we tested the URL to the web service we did it from the same server as the Deployer. We've confirmed via the browser and via WCFStorm (a WCF testing tool) that the SmartTarget service is there and responding - we even executed the "deploy" method with test data and seen it log that on the Fredhopper server. The problem semms to be centering around the FredhopperDeployerModule. We updated the smarttarget_conf.xml to use a file based location instead of the web service with no difference - still get the "Start deploying" log entry, but no file written? – Neil Jan 23 '13 at 12:19
  • Is this issue resolved? I'm running into the same issue. SDL support found the issue is with the creation of the webservice client used to communicate with the SmartTarget deployment webservice. Our deployer runs on WAS6.1 and deployer, SmartTarget runs on separate servers. – Gopi Jasti Apr 2 '14 at 21:40

Is the SmartTarget Publisher Extension installed correctly?

In your Transport Package there should be a section in the component_presentations.xml with extra information. That information is filled by said Publisher Extension.

  • Thanks Gertjan. I had reached the same conclusion - in fact the problem was that the extension wasn't installed on our separate Publisher server!! Grrrr!! I had to copy the SmartTarget publishing DLL from the GAC on the CM server and manually add to the GAC on the Publisher server. Updated Tridion.ContentManager.config and boom - content in Fredhopper. – Neil Jan 28 '13 at 20:58

I would double-check the location for storing the XML files in the properties file of the deployment web service. Then make sure that it can write to that location (use a monitoring tool to check this)

It's supposed to handle errors correctly (and log them) but maybe something is going wrong there.

What happens if you change it from using the deployment web service to storing the XML files on a location on the same server? Does it create the file and does the publishing continue? This would give a clue as to where the problem lies...

  • We did try this, so we changed the smarttarget_conf.xml the Deployer uses to use a file location. No change - the same log entry is written, but the file is not and ultimately publishing fails at the committing stage. Does anyone have a log file for the Smart Target deployer extension to compare - I'd be interested to see what should happen after "Start deploying"! – Neil Jan 23 '13 at 14:01
  • Strange. I would expect some kind of error in this case. Have you looked through all of the files? Just it case the error is logged in the core log file or something... – Peter Kjaer Jan 23 '13 at 14:53
  • Oh and normally you would get an entry afterwards saying "Finished deploying transport package 'D:\Tridion\incoming\Zip\tcm_0-22268-66560.Content\' to Fredhopper." (and some more lines in between, depending on the scenario) – Peter Kjaer Jan 23 '13 at 14:56
  • Some additional info from the core log Peter - something about the onSuccess event? Not sure if its just confirming that something isn;t right, rather than the reason why! – Neil Jan 23 '13 at 15:52
  • The SmartTarget stuff happens in that event, so yeah -- it's just saying that it went wrong. – Peter Kjaer Jan 24 '13 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.