We've just upgraded our server to Windows 2012 which is running IIS8. I'm at a dead end trying to configure it to run Coldfusion 9 and serve the pages.

It installed fine with no errors but I cannot access the Admin panel (it gives me an 404.3 error).

Any advice would be appreciated as I am really struggling and haven't had much to so with servers post Windows 2003.

Thanks in advance.

  • Did you run the web server configuration tool after the install? – Shane Madden Jan 23 '13 at 17:24
  • The solution links are broken. Can some provide alternative links to a solution? – user174297 May 18 '13 at 8:52

I'm pretty sure Adobe will not be updating ColdFusion 9 to run on Windows 8/Server 2012/IIS8. Their most current release, CF10, also does not run under this platform but they are "working on it" with no release date announced yet. Recommendation is to switch to Railo for this platform. I'm not sure if Open Blue Dragon also works under Windows Server 2012 but that could be another alternative.

  • This is a bit late; but the above answer is no longer complete. Adobe has updated ColdFusion 10 to work on Windows Server 2012 [and Windows 8]: helpx.adobe.com/coldfusion/kb/… . I believe it came with a service pack, but I don't see a date. – Reboog711 Sep 25 '13 at 22:49

Are the features required enabled in your IIS settings (for ISAPI Extensions and ISAPI Filters)? The ASP.NET feature may be required as well. I think it is turned on by default. Here is a link to a site with a video showing the installation process along with the settings needed. NOTE: you do not need to enable the IIS Metabase 6 Compatibility mode option if you are installing 9.0.1 or later.

ColdFusion 9 on Windows server 2008 64bit - with video

Installing ColdFusion on IIS 7 + Configure IIS for ColdFusion in Windows Vista and Windows Server 2008

I realize the link I provided references Windows Server 2008 but I think it still relates to Windows Server 2012

And just to be clear - this configuration is NOT supported by Adobe

EDIT - Adding references on how to manually configure IIS



  • Thank you for the links, I will try these today to see if I have any luck with it! – Ben Thomas Jan 24 '13 at 9:34
  • Hi I have done the above and am still having the same issues! Any other ideas? Might have to try and set up a different server like Ben suggests above. – Ben Thomas Jan 24 '13 at 12:42
  • Are you still getting the 404.3 error? Everything I found on that pointed to enabling the ISAPI options. If you had to that on yours you would need to run the web server configuration tool again after doing so. Are ColdFusion pages being processed? If you put a simple index.cfm page in your web root does it get processed? – Miguel-F Jan 24 '13 at 13:16
  • Hi I just tried re running the web server configuration tool and I am getting the error when I submit: Warning, version 8.0 is installed supported versions are 4.x, 5.x, 6.x, 7.x. Any ideas? – Ben Thomas Jan 24 '13 at 13:56
  • Have you tried running the web server configuration tool in Windows 7 Compatibility Mode? I found a couple of articles where that worked for people. You could also attempt to configure the websites manually. Here is an article that explains that process. There are more examples of that if you do some searching. – Miguel-F Jan 24 '13 at 16:29

This link is the most promising one so far that I will try later and probably post back here on my results, not sure if there'd be a difference for CF9 but for your information:


Update ok I just tried this and it worked, took me 4 tries my mistake was that I replaced the msvcrt.dll in the Windows folder the first few times, when you ONLY replace the resources folder that has the JREs and what not, note this is on Windows 8 64-bit - then I ran the installer in compatibility mode for Windows 7 and as an administrator

Another gotcha, you're probably wondering from that article where do I find another working program that uses InstallAnywhere? Well funnily InstallAnywhere installs itself with InstallAnywhere, so get the trial version and follow the steps - you are grabbing the unpacked install files in the AppData/"your name"/Local/Temp/i777777777 (random number here) folder that corresponds to your install

More in depth info: http://thefusionator.com/index.cfm?blogID=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.