I try to connect to a Windows Server 2008; I can get to the login screen but any login attempt fails.

I tried local and domain users, admin/not admin...

Using 'PsExec', I am able to open a remote command line. I created a new user (in case I was wrong about every single credential I tried ), and added it to local administrators.

Still can't connect. (wrong username or password) It has been rebooted. I even disabled the firewall.

What could prevent me from login successfully ?

  • Someone putting an explicity deny ACL would do this. – SpacemanSpiff Jan 23 '13 at 17:58
  • 1
    Are you logging onto the console, or via RDP? – SpacemanSpiff Jan 23 '13 at 17:58
  • Caps Lock or Num Lock? WHat does the Security & System logs show? – uSlackr Jan 24 '13 at 4:18

Make sure the system's time is within 5 minutes of your domain controller for domain logins. Another trick I use is to type the password in the username field to ensure there are no stuck keys or other oddities occurring with the keyboard input.

Check that the users in question are allowed connection via remote desktop. You should be able to check this with the computer management mmc console (should work if psexec is working). Check the local security policy to ensure it is allowing the appropriate users console and remote login permissions.

  • I am able to ping the server within 50ms. And I am positive there is no typo on credentials. I was able to connect to the computer via the computer manager (but not from server manager).I noticed that the dns server in use is not the one I expected. This might prevent access to our domain controler. Now I am stuck trying to change remote dnsserver. Using netsh locally through psexec, I can't modify my network connection because its name contains an accent, and psexec seems not to be able to handle them. – zrz Jan 24 '13 at 9:46
  • And using netsh -r , commands seems to be executed but have no effects on the remote machine. (I can see it using ipconfig /all on the psexec session) – zrz Jan 24 '13 at 9:48

Turns out the DNS Server wasn't one that could resolve the domain controler name. I managed to change DNS settings thanks to psexec and netsh, and now I can login successfully again.

I don't really understand why it has to resolve domain controler name even when one tries a local account.

Also, about using psexec to change DNS settings, I was stuck because my inteface name contains accents, so I had to use the interface position in the interface list, which I had to specify in a binary way:

netsh interface ipv4>set dnsserver "Connexion au réseau local" static 192.168.xxx.xxx

wouldn't work, so I had to use:

netsh interface ipv4>set dnsserver 10 static 192.168.xxx.xxx

I figured the connection number using:

netsh interface ipv4> show ipaddresses

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.