I'm not extremely knowledgeable about servers, so forgive my potential ignorance..

I have a server/site where users in a domain can upload .zip packages to the server. The domain is administered by the IT group at the company, so I can't make any changes there. I do, however, have administrator access to the server itself.

The problem is that the upload feature, which has always worked up until this point, does not work for any domain users, even if I grant them full control, but my personal account (not the administrator one) with the same control works just fine.

So, my question is why can a single user who is given read/write/modify permissions able to upload files normally, where a group of Domain Users with the same permissions cannot.

Note: We are using Windows integrated authentication and the users credentials are being validated correctly. The server returns a 500 - internal server error and mySQL points to the "move_uploaded_file" function with a warning about the destination not existing, but again, it works for single users not in a group. Could group policies be overwriting my security permissions?

Thanks for any help.

EDIT: I think that it's really a permissions and PHP issue. There are two places where the PHP seems to fail. One is calling file_exists(), which returns false for the "Domain Users" group, but true for my admin user. Another is that PHP fails during move_uploaded_file for the "Domain Users" group, but not for my admin user. The Domain Users group has full control over this directory, so what can be wrong that PHP seems to have a permissions issue? PHP safe mode is off and the directory was chmod to 777.

  • 1
    Have you already worked with the IT group at the company to troubleshoot permissions/GPOs/this issue? What did they say? – TheCleaner Jan 24 '13 at 14:45
  • Let's just say that there's a lot of red tape and I probably won't get an answer from them. – execBat Jan 24 '13 at 14:47
  • Without knowing what "upload feature" you are using no one is going to be able to assist you. Please describe this feature in detail. – August Jan 24 '13 at 16:16

If I remember correctly you can separate out the permissions depending on how it is set up. It is entirely possible to set a service up with full permissions for a local user but not set up permissions for a Domain User.

I think this happens "by accident" under some circumstances when you set up permissions on services before adding the server into the domain properly.

I could be completely wrong about this since I am taking from memory from years ago...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.