I'm working at a small company and since I worked tech support about 8 years ago (and have been a Software Engineer for most of the time since then), I'm responsible for all things computer related. I've inherited the current network/server configurations. I'm new to Windows Server 2008 so please be patient with me. I feel like there's an incredibly easy answer to this that I'm just not seeing.

We're using Windows 2008 Server Standard and I'm trying to add a new user to the server for remote in through Remote Desktop and using a database software. I've set the user up in Active Directory and added the user to the RDS group and the Domain Users group and the Domain Admins group (because other users who can log in fine are in that group, though I would prefer to not have this user in that group if I can avoid it). When I login as the user (in the local console or remotely), what loads appears to be Windows Server Manager (or MMC as far as I can tell). There is no start button, and the task bar only has a quick launch button for Server Manager. There are icons on what looks like a desktop, but none of them do anything. Right-clicking on either the "desktop" or the task bar has no effect. If I press Ctrl-Alt-Del and choose Start Task Manager to try and figure out if explorer.exe is running, a window flashes up and then disappears.

I've googled this and searched this forum and StackOverflow, and seen issues that are similar, but not the same. Based on this link I'm guessing that explorer.exe isn't launching - instead MMC/Server Manager is, but I'm not sure about that. I feel like there must be some setting somewhere that I'm missing that will allow explorer.exe to launch and the desktop to be displayed.

Logging in as an administrator (both locally and remotely) works fine, and there are other users (who have the same settings in their AD profiles as the new user I just set up) who login just fine. The only users in the Local Users are the Administrator and one other that I can't remember right now (I'm not at the server location), but the point is that none of the users who current log in fine are there.

  • 2
    Have you tried deleting the user profile and allowing it to be re-created? Does the same thing happen with another new user account? It might be the default profile that's screwed up. Commented Jan 25, 2013 at 22:14
  • 1
    I'd echo deleting the user profile and see if that sorts it. I remember an issue with Vista when the user logs on it hangs at a black screen and explorer doesn't run. If you ctrl-alt-del and start task manager, can you run... and start explorer.exe manually?
    – tombull89
    Commented Jan 25, 2013 at 23:00

2 Answers 2


Since this is an inherited build, it sounds like your predecessor had set up some form of lockdown on the server. I would first check out the GPO to see what runs, and against whom. The user may need to be in a specific OU in Active Directory to get the correct group policies applied.

Other things to check is whether the remote access users have a special logon-script attached to their profile, if there is a logon script on the server, or if you don't have enough licenses for remote desktop (I expect you do, as you say it's happening on console sessions as well).

Hope this helps,


Right, so I know this question is really, really, old, but I wanted to close the loop by saying that I never did figure out what the issue was (I did try deleting and re-adding the user, and there were no login scripts attached to the user's profiles, though I didn't look in the GPO, mainly because I just ran out of time to troubleshoot it). I "solved" the problem by getting a new server. That wasn't the only reason we got a new server, but it did solve the problem. :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .