0

I have setup postfix to use dovecot for authenticating smtp requests. This worked well until yesterday. Now my mail client says the server is offline and telnet for all standard ports yields: Connection Refused. I can send email from the webmail and can connect to the ports with telnet from within the server.

/var/log/mail.log says nothing about this refused connection.

Any ideas on how to get to the bottom of this problem?

0

Seems my ISP has blocked the standard smtp port (25) and my postfix was only running on that port. Changed everything to smtps (port 465) and now it works.

| improve this answer | |
  • Don't use SMTPS; it has been deprecated for a decade now. – adaptr Jan 29 '13 at 10:46
  • So what is the alternative? And does it change anything apart from the port number? – Nicholas Feb 1 '13 at 21:16
  • Use STARTTLS with SASL instead, as amply documented in RFC4409. – adaptr Feb 4 '13 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.