I install svn follow this 5 minutes to set up a subversion server in the cloud

everything fine until this command sudo service httpd restart it said some process already bind port 80

Stopping httpd:                                            [FAILED]
Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs

so I use netstat -lpn | grep :80 to see and found nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf that bind port 80

then I kill that process and use command sudo service httpd restart everything seem fine I can use svn properly.

But I am wrong!
svn work fine but I can't access my website and sub-domain all my sub-domain went to /var/www/html and then I try sudo service nginx restart I got the same problem as before port 80 is already bind and If I kill process that bind to port 80 and restart nginx svn will go down (404 Not Found) and my website will available again

please help. Thank you so much.


Sounds like your website is configured to be served by nginx, and your svn repo is configured to be served by apache/httpd. You need to pick a single web server and stick with it -- bring the configuration for svn over to nginx or your website config over to apache/httpd.

Here's a howto for setting up svn under nginx: http://www.thatsgeeky.com/2011/03/setting-up-subversion/

| improve this answer | |
  • thank so much I have done many things with your suggest and now it work!! thank you very much – hsgu Feb 1 '13 at 8:21

You can run subversion on some other port (8080, for example) and proxy it via nginx.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.