2

We have a 2011 SP1 CM server that we've recently updated with HR1 - it didn't have the Publisher installed as this was on a separate server.

This other server is being re-purposed, so I went and installed the Publisher from the 2011 SP1 CM installer.

Sadly the Publisher service won't start - I get "Error 1068 The dependency service or group failed to start."

Anyone seen this before? Could it be caused by installing a 2011 SP1 Publisher into a 2011 SP1 HR1 CM?

Cheers

2

The only service in the dependencies I can think of are the Transport Service and the Distributed Transaction Controller. Can you validate that that the Transport Service installed and running on that machine? Both of the services in turn depend on Remote Procedure Call. The DTC also uses the Security Accounts Manager. Double check these are all in place.

You might also want to double check you have a valid cd_licenses.xml file for that server, as that is required by the Transport service. If it is there, make sure it has a valid expiry date (or none at all) and has a server name that matches your server in it.

2
  • Thanks Chris, will do. So theres nothing fundamentally wrong with trying to install a 2011 SP1 Publisher into an existing 2011 SP1 HR1 env? – Neil Jan 31 '13 at 13:48
  • I can't think of any reason it should be an issue, but can't say I have ever tried – Chris Summers Jan 31 '13 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.