I'm trying to do a quick evaluation of IBM WebSphere 8.5 on my Ubuntu 12.10 machine. I downloaded a zip archive from the IBM website on a page called "Evaluate IBM WebSphere Application Server Trial"

The description of the zip file is:

Installation Manager 1.5.2 for Linux x86 with WebSphere Application Server Base Trial v8.5

The name of the zip file itself is:


It's 117MB.

After I downloaded this, I unzipped the file. But now I'm lost on how to start the installation. After the unzip, my directory contains the following files:

 ls -altrh
total 116M
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 userinstc
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 userinst
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 installc
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 install
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 groupinstc
-rwxr-xr-x  1 shibo shibo  62K May  9  2010 groupinst
-rwxr-xr-x  1 shibo shibo 7.7K Jan 24  2012 readme_1.5.2.html
-rwxr-xr-x  1 shibo shibo 260K Feb 22  2012 libcairo-swt.so
-rwxr-xr-x  1 shibo shibo  577 Feb 22  2012 about.html
drwxr-xr-x  2 shibo shibo 4.0K Feb 23  2012 features
-rwxr-xr-x  1 shibo shibo  213 Feb 23  2012 user-silent-install.ini
-rwxr-xr-x  1 shibo shibo  159 Feb 23  2012 userinst.ini
-rwxr-xr-x  1 shibo shibo  204 Feb 23  2012 userinstc.ini
-rwxr-xr-x  1 shibo shibo  206 Feb 23  2012 silent-install.ini
-rwxr-xr-x  1 shibo shibo 4.5K Feb 23  2012 repository.xml
-rwxr-xr-x  1 shibo shibo  162 Feb 23  2012 repository.config
-rwxr-xr-x  1 shibo shibo  155 Feb 23  2012 install.ini
-rwxr-xr-x  1 shibo shibo  200 Feb 23  2012 installc.ini
-rwxr-xr-x  1 shibo shibo  157 Feb 23  2012 groupinst.ini
-rwxr-xr-x  1 shibo shibo  202 Feb 23  2012 groupinstc.ini
-rwxr-xr-x  1 shibo shibo 2.2K Feb 23  2012 consoleinst.sh
drwxr-xr-x  2 shibo shibo 4.0K Feb 24  2012 Offerings
drwxr-xr-x 12 shibo shibo 4.0K Feb 24  2012 documentation
drwxr-xr-x  3 shibo shibo 4.0K Feb 24  2012 configuration
drwxr-xr-x  2 shibo shibo 4.0K Feb 24  2012 about_files
drwxr-xr-x  2 shibo shibo 4.0K Feb 24  2012 native
drwxr-xr-x  2 shibo shibo 4.0K Feb 24  2012 license
drwxr-xr-x  4 shibo shibo 4.0K Feb 24  2012 jre_6.0.0.sr9_20110208_03
drwxr-xr-x  2 shibo shibo 4.0K Feb 24  2012 tools
drwxr-xr-x 11 shibo shibo  56K Feb 24  2012 plugins
-rw-r--r--  1 shibo shibo  265 Feb 24  2012 install.Jan-17-2013.14-26-04.orig.xml
drwxr-xr-x 39 shibo shibo 4.0K Dec  9 22:14 ..
-rw-r--r--  1 shibo shibo  799 Jan 17 20:32 install.xml
-rw-rw-r--  1 shibo shibo 115M Jan 31 19:04 BASETRIAL.agent.installer.linux.gtk.x86_1.5.2000.20120223_0907.zip

I tried to run the obvious .sh file, but it doesn't work:

/Downloads$ ./consoleinst.sh 
/tmp/consoleinst-12571.sh: 77: /tmp/consoleinst-12571.sh: /home/shibo/Downloads/./installc: not found

The mentioned path does exist though:

ls -l /home/shibo/Downloads/./installc
-rwxr-xr-x 1 shibo shibo 63005 May  9  2010 /home/shibo/Downloads/./installc

Of course I tried to look at the provided readme, but it really only says the following;

For step-by-step installation instructions, see the installation guide for Installation Manager or refer to the Information Center for the IBM product that you are installing.

Going to the mentioned Information Center only keeps pointing me to other places, until I'm reading documentation that's not even related to anything WebSphere.

To rule out an corrupted archive, I also downloaded the similar express edition:


It's exactly the same, but diff says they do differ. Unpacking that one results in exactly the same structure as shown above, and it's still not possible to run anything.

How can I start this installation of WebSphere 8.5?

  • what is the output of ls -l /home/shibo/Downloads/./installc ?
    – user130370
    Feb 1, 2013 at 13:16
  • Also try looking at files inside "documentation" directory you mentionned
    – user130370
    Feb 1, 2013 at 13:17
  • @EricDANNIELOU see updated answer. I can ls the file and I can less it, but when I try to run it directly via ./installc it also says "bash: ./installc: No such file or directory". I'm beginning to suspect a corrupt archive or download or so :| Unless I'm really missing something.
    – shibo
    Feb 1, 2013 at 14:04
  • @EricDANNIELOU "documentation" only contains folders per language, and each contains just one puny readme.html. The content of that readme.html is what I posted in the question: "see installation guide", "refer to Information Center". It's pretty much completely worthless.
    – shibo
    Feb 1, 2013 at 14:06
  • I'd like to help you more, but downloading the software require registration.
    – user130370
    Feb 1, 2013 at 15:39

2 Answers 2


You downloaded the 32-bit version of WebSphere, but you are using 64-bit Ubuntu (and without 32-bit compatibility libraries installed).

You can resolve this issue in one of two ways:

  1. Download the 64-bit version of WebSphere, if available.
  2. Install the 32-bit compatibility libraries on Ubuntu:

    sudo apt-get install ia32-libs

Run the executable named "install" in your paste, and it will install IBM Installation Manager (IIM) -- if you downloaded this from a WebSphere trial site, it will come pre-loaded with knowledge of the IIM repository for the WebSphere trial.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .