Past few days users are unable to send mail to gmail, by checking the logs I found the following error message "lost connection with gmail-smtp-in.l.google.com while receiving initial server greeting" But there are no issues while sending mail to yahoo, hotmail etc.
->Tried by disabling firewall-no success
->Tried to send by directly connecting without router-no success
->Tried telnet

telnet gmail-smtp-in.l.google.com 25
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.

It just hangs there without sending the 220 greeting

I am narrowing it to ISP network issue, since I am able to telnet to same gmail server from another ISP network

what else could be causing this issue ?


The fact that you were able to establish a connection to the gmail smtp server implies port 25 is not blocked by your ISP. This seems to me, I could be wrong, either a delayed greeting from gmail to deter spam or your IP has been blacklisted. Either way it is the mail server which is preventing your from proceeding to the next level. Try it from a different public IP.

When tests fail before the 220 SMTP server greeting

  • IP is not listed in any of the blacklists. I have tried it from 4 different public IPs of the same ISP no change. – John Feb 2 '13 at 5:43
  • Interesting, because it works from my end. – Daniel t. Feb 2 '13 at 5:47
  • Anything else that i am missing which might be causing this, this started from past 3 days. – John Feb 2 '13 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.