I am hosting my website on site5. Some files have changed, and I use svn to checkin those changes from my development environment and from the website. My svn server is assembla. I am trying to commit files that are on my web hosting server (site5). I have configured the server for the private key and .subversion/config tunnel section too. But I still get this error

svn: Commit failed (details follow): svn: Server sent unexpected return value (405 Method Not Allowed) in response to MKCOL request for ''

I have tried most famous question for this issue. This did not work for me.

Edit :

  • SVN Server is assembla and the Site5 webserver is the client.
  • On the site5 webserver in ~/subversion/config under [tunnel] section I have site5 = /usr/bin/ssh -p 22 -q -l <loginid> -i <pathtoprivatekey>
  • Command I am trying `svn commit -m "message"
  • Also tried svn commit -m "message" svn+ssh://<username>/<domain>/<fullpath>
  • Both command same error

closed as off topic by Michael Hampton, Khaled, Scott Pack, mdpc, Ward Feb 3 '13 at 6:28

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please provide more detail about what configuration you've put in place, what you've tried, where you're trying to commit to, and what you're doing to try to commit. – Shane Madden Feb 2 '13 at 7:45
  • added more details, hope this helps. – Siddharth Feb 2 '13 at 7:55
  1. Title of your question unrelated to body - you have troubles with Assembla SVN, not with site5
  2. Assembla Subversion repository never was and isn't accessible with svn+ssh://, only https:// - Source/SVN - Source subtab always show URL of repository

https://subversion.assembla.com/svn/SPACENANE/ (f repository was not renamed by hand)

  • Neat, why didn't I think of it. Thanks. – Siddharth Feb 2 '13 at 16:01
  • 1
    You can always edit a question to make it more clear. :) – Michael Hampton Feb 2 '13 at 17:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.