0

I'm really struggling to get a website up and running for the NHS. Apologies in advance as it's the first time I've had to setup a domain without using NS records so I'm a tad out of my depth. I should add, the domain is managed by the NHS who don't allow the use of NS records or me to manage the domain myself.

The URL is parkparadesurgery.nhs.uk and has an A-record pointing to the server IP (46.23.71.90). I thought this would have been enough on its own but it wouldn't resolve and so UK2 recommended I add a CNAME pointing to the subdomain (parkparadesurgery.becketsrestaurant.co.uk - this address works). Both the cname and a-record on the new domain have propagated properly but the site is still not working.

I've added parkparadesurgery.nhs.uk to my hosting account as an addon domain. Is there anything else I need to do to get it to resolve?

Many thanks for your help, it's very much appreciated...the site has been down for a number of days and a lot of people rely on it for important health matters.

Many thanks Jonny

0

www.parkparadesurgery.nhs.uk is currently working. It has a CNAME record pointing at parkparadesurgery.becketsrestaurant.co.uk, which points at your IP address.

However, as soon as I connect to your server and request a webpage, your server is redirecting me to parkparadesurgery.nhs.uk (without the www.) which has no A record and does not work.

If you could configure your web application to run on www.parkparadesurgery.nhs.uk and not redirect, it would work. (Although really they could do with asking the NHS domain admins to add an A record for parkparadesurgery.nhs.uk pointing at your server. Ideally a domain entered without 'www.' should still get you to the relevant website)

  • USD Matt, Thank you so much. Why tech support couldn't tell me that 3 days ago I don't know. Thanks. I'll get the NHS to add a blank a-record for the non-www version. In the meantime how would one usually configure the server to stop redirecting it to the non-www version. I haven't told it to as far as I know and my .htaccess file is empty? I'm using cPanel. Thanks again, much appreciated! – JonnyHarper Feb 4 '13 at 17:30
  • Probably a bit late now but I suspect the redirect was probably done by Wordpress. I see the A record for the root domain is now in place and the site is fully working on the www. address. – USD Matt Feb 5 '13 at 9:38
  • Yeah it was. Thanks anyway. On the phone for ages to tech support and have an actual solution on here within minutes! – JonnyHarper Feb 5 '13 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.