7

we are configuring DNS for a GMail service, the MX records are configured as to Google says, however, in the DNS check, there is a warning:

SPF must allow Google to send mail on behalf of the domain

My questions:

  • Why is the SPF record for GMail a problem?

  • How to resolve that issue?

Many thanks for your help!Google Mail error

2 Answers 2

3

You need to add a SPF DNS record in your DNS server (SPF = Sender Policy Framework). The value of this record is provided in your screenshot already.

It is highly recommended to add not only the SPF record but also a TXT record with the same value. The SPF record will tell receiving Emailservers that the Gmail servers are permitted to send Emails using your domain as sender (details: http://en.wikipedia.org/wiki/Sender_Policy_Framework).

If you have a domain provider who is giving you access to his DNS servers, then there might be a special option to set it up easily for you.

2
  • 2
    What does "add not only the SPF record but also a TXT record" mean? I have added @ IN TXT "v=spf1 include:_spf.google.com ~all" and I get the same error.
    – erdomester
    Commented Oct 30, 2013 at 22:11
  • Please develop the answer @Ben with what to put in records
    – secavfr
    Commented Jan 8, 2022 at 12:00
1

I had a record only authorizing emails to be sent from my specific server IP. Here is my final SPF record that works :

v=spf1 +mx +a +ip4:xxx.xxx.xxx.xxx include:_spf.google.com ~all

Google SPF documentation helped me : https://support.google.com/a/answer/10685031

1
  • wow. that was a very deep grave you dug this question out of :D
    – MoWo
    Commented Jan 8, 2022 at 12:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .