2

When I rebooted my server I got the following error: enter image description here

What can I do to get the server back up? I tried running lvremove /dev/vg1/snaps but get the message: File based locking initialization failed

I tried running fsck -fp /dev/vg1/snaps and that results in: /dev/mapper/vg1-snaps: 11/65536 files (0.0% non-contiguous), 12635/262144 blocks Rebooting after this saw the same problem

I don't know if this is good or bad. There is no data on that partition (os just installed). Any ideas what I can do to fix or remove this problem?

2

All you need to do in this case is comment out the /etc/fstab entry for the offending partition. You may need to remount the root filesystem as read-write:

mount -o remount,rw /

Then edit the /etc/fstab and place a comment (#) on the line of the snaps partition. Save and reboot.

  • thanks yah, I did have to remount the / filesystem before I could change /etc/fstab, then just comment out the relevant line. – Programster Feb 5 '13 at 21:23
0

Ewwhite's answer is excellent; if that doesn't work, given that you mentioned it's a fresh install, would be to try another fresh install (and be very, very careful about how you set up partitions.) Sometimes time fixing a problem by popping the hood is 3x > than simply resetting the engine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.