I have a weird issue:

On a VMware 5.1.0 installed on a Dell R620, the network adapter gets disconnected. enter image description here

enter image description here

Hitting the 'D' button for additional info, shows the following. enter image description here

  • I tried to reset the iDrac - with no results.
  • the iDrac shows the network cable connected enter image description here

  • Testing the management network fails enter image description here

  • I tried the reset Management network - (ofc, not with hopes but I had to try) enter image description here

But the adapter is still disconnected.

  • it is connected to an HP switch - resetting the switch didn't change
  • Yes, I did replace the cable :-/
  • Dell has already replaced one network interface (this is the new one = previous had the same behavior)

  • The only thing that works is a full shutdown/power up cycle - of the host - which is ofc not the solution.

  • I am not sure what to look for in the system logs.

  • Is there a VM patch I need to look for?

-- UPDATE: I have moved my VM's to another vswitch, leaving only the management network on NIC1 (this was after a restart) and everything worked - after some time (can't say exactly) the same thing happned: vmnic0 has become disconnected (with only the management network on it)

  • 1
    And you don't have multiple NICs for your management network? – ewwhite Feb 5 '13 at 22:25
  • I'd love to hear why, but I don't have HA, no cluster, no isolated ip, so no, I don't have another one setup. – Saariko Feb 5 '13 at 22:36
  • 1
    Does hitting D to get details on the network adapter give you any additional information? And are the link lights on the adapter? – Shane Madden Feb 6 '13 at 6:34
  • 1
    Call me crazy here... have you replaced the cable? – SpacemanSpiff Feb 6 '13 at 14:19
  • 1
    This is a firmware issue. – ewwhite Feb 6 '13 at 15:43

A few quick items to resolve this:

enter image description here


The issue can be maybe because you changed the speed and duplex of vmnic, try to reset it, login in support mode and list your vmnic and see if is 0mbps this mean that you've changed the settings.

first see details with: esxcfg-nics -l So reset in this way: esxcfg-nics -a vmnic1 or esxcfg-nics -s 100 -d full vmnic1

More details here: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004089


Apparently the issue was with a broken/malfunctioning adapter.

Manufacturer replaced it, and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.